summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-11-16 04:37:46 +0100
committerChristopher Arndt2023-11-16 04:37:46 +0100
commit817f6e4b68a72a6b4b49c20f74cacda7e7187f6c (patch)
treeae22ea71157a8629235335d62636ce614c421a36
parent8dc87e1573d6aaadc0360c6bed1cf4492c79d86b (diff)
downloadaur-817f6e4b68a72a6b4b49c20f74cacda7e7187f6c.tar.gz
Remove obsolete patch
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
-rw-r--r--fix-asprintf.patch22
4 files changed, 6 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 607a9d488c1f..257d49bc7497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xtinyterror.lv2-git
pkgdesc = An amp simulation LV2 plugin modelled after a small british valve amp (git version)
- pkgver = r15.015b055
- pkgrel = 4
+ pkgver = r16.6f9cc71
+ pkgrel = 1
url = https://github.com/brummer10/XTinyTerror.lv2
arch = x86_64
groups = pro-audio
@@ -19,10 +19,8 @@ pkgbase = xtinyterror.lv2-git
conflicts = xtinyterror.lv2
source = xtinyterror.lv2::git+https://github.com/brummer10/XTinyTerror.lv2.git
source = xputty::git+https://github.com/brummer10/Xputty.git
- source = fix-asprintf.patch::https://github.com/brummer10/libxputty/commit/7eb70bf3f7bce0af9e1919d6c875cdb8efca734e.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 15fe7e3e2ec8efe62dc9bb4c0830eaf3ed0373cd39ebd755f2d9193710ebbf76
pkgname = xtinyterror.lv2-git
depends = gcc-libs
diff --git a/.gitignore b/.gitignore
index 3e31c5af570f..733f9a0df3a5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,6 @@
-.AURINFO
pkg/
src/
xtinyterror.lv2/
xputty/
-xtinyterror.lv2-git-*.tar.xz
-xtinyterror.lv2-git-*.tar.zst
+xtinyterror.lv2-git-*.pkg.tar.*
xtinyterror.lv2-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5d20516c35d8..555f87725f22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ _reponame=XTinyTerror.lv2
_pkgname=xtinyterror.lv2
_lv2uri="http://guitarix.sourceforge.net/plugins/${_reponame//.lv2}_#_tinyterror_"
pkgname=$_pkgname-git
-pkgver=r15.015b055
-pkgrel=4
+pkgver=r16.6f9cc71
+pkgrel=1
pkgdesc='An amp simulation LV2 plugin modelled after a small british valve amp (git version)'
arch=(x86_64)
url='https://github.com/brummer10/XTinyTerror.lv2'
@@ -18,11 +18,9 @@ conflicts=($_pkgname)
source=(
"$_pkgname::git+https://github.com/brummer10/$_reponame.git"
'xputty::git+https://github.com/brummer10/Xputty.git'
- 'fix-asprintf.patch::https://github.com/brummer10/libxputty/commit/7eb70bf3f7bce0af9e1919d6c875cdb8efca734e.patch'
)
sha256sums=('SKIP'
- 'SKIP'
- '15fe7e3e2ec8efe62dc9bb4c0830eaf3ed0373cd39ebd755f2d9193710ebbf76')
+ 'SKIP')
pkgver() {
@@ -40,9 +38,6 @@ prepare() {
git submodule init
git config submodule.Xputty.url "${srcdir}/xputty"
git -c protocol.file.allow=always submodule update
-
- cd libxputty
- patch -p1 -N -r - -i "$srcdir"/fix-asprintf.patch || true
}
build() {
diff --git a/fix-asprintf.patch b/fix-asprintf.patch
deleted file mode 100644
index 7eca29903d8e..000000000000
--- a/fix-asprintf.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 7eb70bf3f7bce0af9e1919d6c875cdb8efca734e Mon Sep 17 00:00:00 2001
-From: brummer10 <brummer-@web.de>
-Date: Sun, 20 Aug 2023 09:54:21 +0200
-Subject: [PATCH] Fix issue #12 Fails to build with glibc 2.38 and
- -Werror=format-security
-
----
- xputty/xfilepicker.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/xputty/xfilepicker.c b/xputty/xfilepicker.c
-index 7e77fab..e76cac6 100644
---- a/xputty/xfilepicker.c
-+++ b/xputty/xfilepicker.c
-@@ -222,6 +222,6 @@ void fp_init(FilePicker *filepicker, const char *path) {
- filepicker->selected_file = NULL;
- filepicker->path = NULL;
- filepicker->filter = NULL;
-- asprintf(&filepicker->path, path);
-+ asprintf(&filepicker->path, "%s", path);
- assert(filepicker->path != NULL);
- }