summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-10-16 23:28:03 +0200
committerChristopher Arndt2023-10-16 23:28:03 +0200
commit86d73dfc882a3963775792c7d72c18e58c3dc417 (patch)
treea9a10c4b374dc5956cf701924c66c010077391f3
parent45f6f9fb626ccac6dd38e9c462815565d49dc0c6 (diff)
downloadaur-86d73dfc882a3963775792c7d72c18e58c3dc417.tar.gz
Fix build error with glibc 2.38 and -Werror=format-security
Also fix namcap custom license error and make (lib)cairo dep a soname depependency.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD58
-rw-r--r--fix-asprintf.patch22
3 files changed, 69 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63ac6364015b..76f4deb44cbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,31 @@
pkgbase = xtinyterror.lv2-git
- pkgdesc = An amplifier simulation LV2 plugin modelled after a small british valve amp (git version)
+ pkgdesc = An amp simulation LV2 plugin modelled after a small british valve amp (git version)
pkgver = r15.015b055
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/brummer10/XTinyTerror.lv2
- arch = i686
arch = x86_64
groups = pro-audio
groups = lv2-plugins
- license = 0BSD
+ license = custom:0BSD
+ makedepends = cairo
makedepends = git
makedepends = lv2
makedepends = lv2lint
makedepends = xxd
- depends = cairo
depends = gcc-libs
+ depends = glibc
depends = libx11
provides = xtinyterror.lv2
- provides = xtinyterror.lv2=r15.015b055
- provides = xtinyterror.lv2
- conflicts = xtinyterror.lv2
conflicts = xtinyterror.lv2
source = xtinyterror.lv2::git+https://github.com/brummer10/XTinyTerror.lv2.git
source = xputty::git+https://github.com/brummer10/Xputty.git
- md5sums = SKIP
- md5sums = SKIP
+ source = fix-asprintf.patch::https://github.com/brummer10/libxputty/commit/7eb70bf3f7bce0af9e1919d6c875cdb8efca734e.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 15fe7e3e2ec8efe62dc9bb4c0830eaf3ed0373cd39ebd755f2d9193710ebbf76
pkgname = xtinyterror.lv2-git
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ depends = libcairo.so
diff --git a/PKGBUILD b/PKGBUILD
index a076e0473264..2fd48f0388fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,30 @@
_reponame=XTinyTerror.lv2
_pkgname=xtinyterror.lv2
_lv2uri="http://guitarix.sourceforge.net/plugins/${_reponame//.lv2}_#_tinyterror_"
-pkgname="${_pkgname}-git"
+pkgname=$_pkgname-git
pkgver=r15.015b055
-pkgrel=2
-pkgdesc="An amplifier simulation LV2 plugin modelled after a small british valve amp (git version)"
-arch=('i686' 'x86_64')
-url="https://github.com/brummer10/${_reponame}"
-license=('0BSD')
-depends=('cairo' 'gcc-libs' 'libx11')
-makedepends=('git' 'lv2' 'lv2lint' 'xxd')
-groups=('pro-audio' 'lv2-plugins')
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}" "${_pkgname//-/.}")
-conflicts=("${_pkgname}" "${_pkgname//-/.}")
-source=("${_pkgname}::git+https://github.com/brummer10/${_reponame}.git"
- 'xputty::git+https://github.com/brummer10/Xputty.git')
-md5sums=('SKIP'
- 'SKIP')
+pkgrel=3
+pkgdesc='An amp simulation LV2 plugin modelled after a small british valve amp (git version)'
+arch=(x86_64)
+url='https://github.com/brummer10/XTinyTerror.lv2'
+license=(custom:0BSD)
+depends=(gcc-libs glibc libx11)
+makedepends=(cairo git lv2 lv2lint xxd)
+groups=(pro-audio lv2-plugins)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=(
+ "$_pkgname::git+https://github.com/brummer10/$_reponame.git"
+ 'xputty::git+https://github.com/brummer10/Xputty.git'
+ 'fix-asprintf.patch::https://github.com/brummer10/libxputty/commit/7eb70bf3f7bce0af9e1919d6c875cdb8efca734e.patch'
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ '15fe7e3e2ec8efe62dc9bb4c0830eaf3ed0373cd39ebd755f2d9193710ebbf76')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
# no release yet and no version number anywhere in the sources
#local ver="$(grep '^\s*VER =' Xmonk/Makefile | cut -d ' ' -f 3)"
@@ -31,33 +35,39 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
git submodule init
git config submodule.Xputty.url "${srcdir}/xputty"
git -c protocol.file.allow=always submodule update
+
+ cd libxputty
+ patch -p1 -N -r - -i "$srcdir"/fix-asprintf.patch
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
+
make
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
+
mkdir -p lv2
ln -sf ../${_reponame//.lv2}/${_reponame} lv2/${_reponame}
# expected to produce errors
#sord_validate -l "${PWD}/lv2/${_reponame}"/*.ttl || :
- LV2_PATH="${PWD}/lv2:/usr/lib/lv2" lv2lint -M pack "${_lv2uri}"
+ LV2_PATH="$PWD/lv2:/usr/lib/lv2" lv2lint -M pack "$_lv2uri"
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
+ depends+=(libcairo.so)
+ cd $_pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
# documentation
- install -vDm 644 README.md "${_reponame//.lv2}.png" -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -vDm 644 README.md "${_reponame//.lv2}.png" -t "$pkgdir"/usr/share/doc/$pkgname
# license
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}
diff --git a/fix-asprintf.patch b/fix-asprintf.patch
new file mode 100644
index 000000000000..7eca29903d8e
--- /dev/null
+++ b/fix-asprintf.patch
@@ -0,0 +1,22 @@
+From 7eb70bf3f7bce0af9e1919d6c875cdb8efca734e Mon Sep 17 00:00:00 2001
+From: brummer10 <brummer-@web.de>
+Date: Sun, 20 Aug 2023 09:54:21 +0200
+Subject: [PATCH] Fix issue #12 Fails to build with glibc 2.38 and
+ -Werror=format-security
+
+---
+ xputty/xfilepicker.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xputty/xfilepicker.c b/xputty/xfilepicker.c
+index 7e77fab..e76cac6 100644
+--- a/xputty/xfilepicker.c
++++ b/xputty/xfilepicker.c
+@@ -222,6 +222,6 @@ void fp_init(FilePicker *filepicker, const char *path) {
+ filepicker->selected_file = NULL;
+ filepicker->path = NULL;
+ filepicker->filter = NULL;
+- asprintf(&filepicker->path, path);
++ asprintf(&filepicker->path, "%s", path);
+ assert(filepicker->path != NULL);
+ }