summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2019-03-09 15:11:34 -0500
committerAndrew O'Neill2019-03-09 15:11:34 -0500
commit6bab5c70fc51fcd3f26ba920e38e922f5b0598b7 (patch)
tree3bc605158033bdfe831fc0c7514eca43a24198aa
parent34d86b93f3ac8a9532d77fb3e615ae397b499a0f (diff)
downloadaur-6bab5c70fc51fcd3f26ba920e38e922f5b0598b7.tar.gz
Adopted, and bumped version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48e55bc66280..5e6e4365840b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = xtitle
pkgdesc = Outputs X window titles
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
url = https://github.com/baskerville/xtitle
- arch = i686
arch = x86_64
license = custom:Unlicense
depends = libxcb
depends = xcb-util-wm
depends = xcb-util
- provides = xtitle
- conflicts = xtitle
conflicts = xtitle-git
- source = xtitle-0.4.3.tar.gz::https://github.com/baskerville/xtitle/archive/0.4.3.tar.gz
- md5sums = 78c531089280b5b88a77ca06b6c74dd2
+ source = https://github.com/baskerville/xtitle/archive/0.4.4.tar.gz
+ sha256sums = c2fbf403892c4e466e43528415284a458d4354855f221273881aa4388d028970
pkgname = xtitle
diff --git a/PKGBUILD b/PKGBUILD
index 28b1beaf8729..a41c58489e30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Eisfreak7 <eisfreak7@gmail.com>
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Contributor: Eisfreak7 <eisfreak7@gmail.com>
pkgname=xtitle
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc='Outputs X window titles'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/baskerville/${pkgname}"
license=('custom:Unlicense')
depends=('libxcb' 'xcb-util-wm' 'xcb-util')
-provides=("${pkgname}")
-conflicts=("${pkgname}" "${pkgname}-git")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-md5sums=('884843193195e8b6293bafd510ecb69e')
+conflicts=("${pkgname}-git")
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('c2fbf403892c4e466e43528415284a458d4354855f221273881aa4388d028970')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr
+ cd "${pkgname}-${pkgver}"
+
+ make PREFIX=/usr
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr DESTDIR="$pkgdir" install
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}-${pkgver}"
+
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}