summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-18 23:02:12 +0300
committerCaleb Maclennan2023-03-18 23:02:12 +0300
commit715ac37777435917df4084d079181b6b01f37da4 (patch)
treee0bf348a676e6e77f5d5b5217766d72b95fab657
downloadaur-715ac37777435917df4084d079181b6b01f37da4.tar.gz
Initial upload: xts 0.0.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0e9233bfc12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xts
+ pkgdesc = XML typesetting system, experimental playground for speedata Publisher next generation
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/speedata/xts
+ arch = x86_64
+ license = AGPL3
+ makedepends = go
+ depends = glibc
+ source = https://github.com/speedata/xts/archive/v0.0.1/xts-0.0.1.tar.gz
+ sha256sums = e28b1401e4e2b863a2d33e45acb98e20c9cace2e6476befc7f54705685d5879c
+
+pkgname = xts
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc94b04935de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=xts
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='XML typesetting system, experimental playground for speedata Publisher next generation'
+arch=(x86_64)
+url="https://github.com/speedata/$pkgname"
+license=(AGPL3)
+depends=(glibc)
+makedepends=(go)
+_archive="$pkgname-$pkgver"
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
+sha256sums=('e28b1401e4e2b863a2d33e45acb98e20c9cace2e6476befc7f54705685d5879c')
+
+prepare() {
+ cd "$_archive"
+ mkdir -p build
+}
+
+build() {
+ cd "$_archive"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_LDFLAGS="$LDFLAGS"
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-extldflags \"$LDFLAGS\"" \
+ -o build \
+ ./...
+}
+
+package() {
+ cd "$_archive"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "build/$pkgname"
+}