summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorentexsoft2020-01-01 19:04:30 +0100
committerentexsoft2020-01-01 19:04:30 +0100
commit7e800e6a8998392b25f4cf8d287ad0a939641c57 (patch)
tree4ff882ec4973d0a5dcc0df39fac0985737ff1e9a
downloadaur-7e800e6a8998392b25f4cf8d287ad0a939641c57.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5db47b2ac30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xts-dark-theme
+ pkgdesc = Dark theme for xfce4-theme switcher.
+ pkgver = 0.1
+ pkgrel = 0
+ url = https://gitlab.com/linux-stuffs/xts-themes
+ arch = any
+ groups = xfce4-goodies
+ license = GPL3
+ depends = xfce4-theme-switcher
+ depends = xfce4-whiskermenu-plugin
+ depends = arc-gtk-theme
+ depends = gtk-engines
+ depends = plank
+ depends = conky
+ optdepends = conky-manager
+ provides = xts-dark-theme
+ conflicts = xts-dark-theme
+ options = !strip
+ source = https://gitlab.com/linux-stuffs/xts-themes/raw/master/xts-dark-theme/distrib/xts-dark-theme-0.1-0.tar.gz
+ sha256sums = SKIP
+
+pkgname = xts-dark-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e013adae8095
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Pavel Sibal <entexsoft@gmail.com>
+pkgname=xts-dark-theme
+pkgver=0.1
+pkgrel=0
+pkgdesc="Dark theme for xfce4-theme switcher."
+arch=('any')
+url="https://gitlab.com/linux-stuffs/xts-themes"
+license=('GPL3')
+groups=('xfce4-goodies')
+
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+depends=('xfce4-theme-switcher' 'xfce4-whiskermenu-plugin' 'arc-gtk-theme' 'gtk-engines' 'plank' 'conky')
+optdepends=('conky-manager')
+options=('!strip')
+
+source=('https://gitlab.com/linux-stuffs/xts-themes/raw/master/xts-dark-theme/distrib/xts-dark-theme-0.1-0.tar.gz')
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr
+ make install DESTDIR="${pkgdir}"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp --no-preserve=ownership "${pkgdir}/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}