summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 16:28:00 +0200
committerMattias Andrée2015-06-11 16:28:00 +0200
commitb825ac2408f36068f01f037088dcd13f4c6711b1 (patch)
tree817358b9eaf13c05a4b12aaa555ab3ef47f2398b
downloadaur-xtux.tar.gz
Initial import, version 20030306
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
-rw-r--r--xtux.desktop8
-rw-r--r--xtux.patch37
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dd3f90f3a87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xtux
+ pkgdesc = A Gauntlet-style arcade game for X11 with multiplayer mode
+ pkgver = 20030306
+ pkgrel = 1
+ url = http://xtux.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxpm
+ source = http://downloads.sourceforge.net/xtux/xtux-src-20030306.tar.gz
+ source = xtux.patch
+ source = xtux.desktop
+ md5sums = 6ca5d3b48c30411d1a64b4316d5cf6a9
+ md5sums = d04e19ea067837eda0f1ce066d9c8f3a
+ md5sums = 504541ae6fadcb6d56387aedda475979
+
+pkgname = xtux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad04e5325e55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Previous maintainer: Anton Bazhenov <anton.bazhenov at gmail>
+
+pkgname=xtux
+pkgver=20030306
+pkgrel=1
+pkgdesc="A Gauntlet-style arcade game for X11 with multiplayer mode"
+arch=('i686' 'x86_64')
+url="http://xtux.sourceforge.net/"
+license=('GPL')
+depends=('libxpm')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-src-${pkgver}.tar.gz"
+ "${pkgname}.patch"
+ "${pkgname}.desktop")
+md5sums=('6ca5d3b48c30411d1a64b4316d5cf6a9'
+ 'd04e19ea067837eda0f1ce066d9c8f3a'
+ '504541ae6fadcb6d56387aedda475979')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ patch -Np1 -i "../${pkgname}.patch"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ # Install binaries
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m755 "${pkgname}" tux_serv "${pkgdir}/usr/bin"
+
+ # Install data files
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -r data/* "${pkgdir}/usr/share/${pkgname}"
+
+ # Install pixmap and .desktop file
+ install -Dm644 data/images/icon.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+ install -Dm644 "../${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Install documentation
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 AUTHORS CHANGELOG README* "${pkgdir}/usr/share/doc/${pkgname}"
+}
diff --git a/xtux.desktop b/xtux.desktop
new file mode 100644
index 000000000000..4c5d17b4f63c
--- /dev/null
+++ b/xtux.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=XTux
+Comment=A Gauntlet-style arcade game for X11 with multiplayer mode
+Exec=xtux
+Icon=xtux.xpm
+Terminal=false
+Categories=Game;ActionGame;
diff --git a/xtux.patch b/xtux.patch
new file mode 100644
index 000000000000..2ace5e9fa07c
--- /dev/null
+++ b/xtux.patch
@@ -0,0 +1,37 @@
+--- xtux.orig/Makefile 2003-02-04 20:59:01.000000000 +0500
++++ xtux/Makefile 2012-02-26 16:31:00.092498256 +0600
+@@ -5,7 +5,7 @@
+ #============================================================#
+
+ #Change this to where you want to put the data directory.
+-DATADIR = `pwd`/data
++DATADIR = /usr/share/xtux
+ #Eg you might want to put the data files here......
+ #DATADIR = /usr/share/games/xtux
+
+--- xtux.orig/src/client/win.h 2003-03-05 20:20:04.000000000 +0500
++++ xtux/src/client/win.h 2012-02-26 15:59:09.479154124 +0600
+@@ -11,9 +11,9 @@
+ #define DEF_WIN_H 384
+
+ /* Font names */
+-#define MED_FONT_18 "-adobe-helvetica-medium-r-*-*-18-*-*-*-*-*-*-*"
+-#define BOLD_FONT_14 "-*-helvetica-bold-r-*-*-14-*-*-*-*-*-iso8859-*"
+-#define BOLD_FONT_24 "-*-helvetica-bold-r-*-*-24-*-*-*-*-*-iso8859-*"
++#define MED_FONT_18 "-*-*-medium-r-*-*-18-*-*-*-*-*-*-*"
++#define BOLD_FONT_14 "-*-*-bold-r-*-*-14-*-*-*-*-*-iso8859-*"
++#define BOLD_FONT_24 "-*-*-bold-r-*-*-24-*-*-*-*-*-iso8859-*"
+
+ typedef struct {
+ Display *d;
+--- xtux.orig/src/client/menu.c 2003-03-05 19:54:17.000000000 +0500
++++ xtux/src/client/menu.c 2012-02-26 19:52:47.701065955 +0600
+@@ -726,7 +726,7 @@
+ for( i=0 ; i<3 ; i++ )
+ close(i); /* Close STD-IN, -OUT, -ERR */
+
+- system("./tux_serv -e");
++ system("tux_serv -e");
+ /* execlp( "./tux_serv", "-e" );
+ perror("execlp"); */
+ exit(-1);