summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2020-09-04 00:41:06 +0100
committerConnor Behan2020-09-04 00:41:06 +0100
commitf21c10d4739f7f1100d67ed2cce6775fba378326 (patch)
treeab4f19c243af8e9cf5472621bec1e6ef5d4c4e26
parentde8133fb5fe94e577161ea425b764d8400606340 (diff)
downloadaur-f21c10d4739f7f1100d67ed2cce6775fba378326.tar.gz
Build fixes due to inugroho
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--gettid.patch17
-rw-r--r--sysctl.patch15
4 files changed, 51 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37fb96b623f8..d0a7c66b0b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xulrunner
pkgdesc = Mozilla Runtime Environment
pkgver = 41.0.2
- pkgrel = 16
+ pkgrel = 17
url = http://wiki.mozilla.org/XUL:Xul_Runner
arch = x86_64
license = MPL
@@ -30,6 +30,8 @@ pkgbase = xulrunner
depends = libvpx
depends = icu
depends = python2
+ depends = libpng-apng
+ depends = alsa-lib
replaces = xulrunner-oss
options = !emptydirs
options = !makeflags
@@ -45,6 +47,8 @@ pkgbase = xulrunner
source = shared-libs.patch
source = sed43.patch
source = gcc6.diff
+ source = sysctl.patch
+ source = gettid.patch
sha256sums = f7abb2e2989779305ab1f80d30caf9fc55d96c7e66d1394e2cc9639442e2b864
sha256sums = 8ab57ae3ba4660a721cdb210babee02488b670d9af9fdecf5da3b832d77e342b
sha256sums = 3aea9a83bf304da5525f34a911712cf42f8ded1c8b6becf0a2cf8a4b4f7facd6
@@ -56,6 +60,8 @@ pkgbase = xulrunner
sha256sums = 59d9fc421bc10a5515b73e159f44a72365bf7b7e8b3fc8a8c46043ef40bd3a40
sha256sums = e9b7199b57fa07e440d37db0cc3cf52aa1c1fd7d5e8b31db14e511d77b5ce327
sha256sums = 0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098
+ sha256sums = 8b921488faff947baf26ebba6db09d9d6db396b0d528aa543a4da20330c1d8fd
+ sha256sums = fc1b55fda12dd1d02cea54d530a594855d45fe0be93bc06f4c804618b0700b2b
pkgname = xulrunner
diff --git a/PKGBUILD b/PKGBUILD
index 419dff0cb46d..d603d1d7b55d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
pkgname=xulrunner
pkgver=41.0.2
-pkgrel=16
+pkgrel=17
pkgdesc="Mozilla Runtime Environment"
arch=('x86_64')
license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2' 'mozilla-common' 'nss>3.18' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'libpulse' 'libevent' 'libvpx' 'icu' 'python2')
+depends=('gtk2' 'mozilla-common' 'nss>3.18' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'libpulse' 'libevent' 'libvpx' 'icu' 'python2' 'libpng-apng' 'alsa-lib')
makedepends=('gcc6' 'zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'gconf' 'autoconf2.13' 'gst-plugins-base-libs')
url="http://wiki.mozilla.org/XUL:Xul_Runner"
source=(https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/xulrunner-$pkgver.source.tar.xz
@@ -22,7 +22,9 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/sourc
mozilla-pkgconfig.patch
shared-libs.patch
sed43.patch
- gcc6.diff)
+ gcc6.diff
+ sysctl.patch
+ gettid.patch)
options=('!emptydirs' '!makeflags' 'staticlibs')
replaces=('xulrunner-oss')
sha256sums=('f7abb2e2989779305ab1f80d30caf9fc55d96c7e66d1394e2cc9639442e2b864'
@@ -35,8 +37,9 @@ sha256sums=('f7abb2e2989779305ab1f80d30caf9fc55d96c7e66d1394e2cc9639442e2b864'
'1aa9ebe67542a2b8c28905d070829ada5b29438c6a7961f2b0cdd6b92d8b9f5c'
'59d9fc421bc10a5515b73e159f44a72365bf7b7e8b3fc8a8c46043ef40bd3a40'
'e9b7199b57fa07e440d37db0cc3cf52aa1c1fd7d5e8b31db14e511d77b5ce327'
- '0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098')
-
+ '0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098'
+ '8b921488faff947baf26ebba6db09d9d6db396b0d528aa543a4da20330c1d8fd'
+ 'fc1b55fda12dd1d02cea54d530a594855d45fe0be93bc06f4c804618b0700b2b')
prepare() {
cd "$srcdir/mozilla-release"
cp "$srcdir/mozconfig" .mozconfig
@@ -58,6 +61,10 @@ prepare() {
# Fix for Bug 1329798 "Use of major & minor macros without including sys/sysmacros.h"
patch -Np1 -i ../0001-Bug-1329798-Include-sys-sysmacros.h-for-major-minor-on-Linux.patch
+ # Fix for removing sys/sysctl.h and declaration of gettid
+ patch -Np1 -i ../sysctl.patch
+ patch -Np1 -i ../gettid.patch
+
# https://bugzilla.mozilla.org/show_bug.cgi?id=847568
patch -Np1 -i ../LFS_graphite2_harfbuzz.patch
sed -i -e "s|lcrmf|lm|g" configure.in
diff --git a/gettid.patch b/gettid.patch
new file mode 100644
index 000000000000..d86b2c2959ed
--- /dev/null
+++ b/gettid.patch
@@ -0,0 +1,17 @@
+--- src/tools/profiler/platform-linux-lul.h 2015-10-15 04:41:22.000000000 +0700
++++ work/tools/profiler/platform-linux-lul.h 2020-09-03 22:46:43.264756553 +0700
+@@ -21,10 +21,10 @@
+ #if defined(__GLIBC__)
+ #include <unistd.h>
+ #include <sys/syscall.h>
+-static inline pid_t gettid()
+-{
+- return (pid_t) syscall(SYS_gettid);
+-}
++// static inline pid_t gettid()
++// {
++// return (pid_t) syscall(SYS_gettid);
++// }
+ #endif
+
+ // A singleton instance of the library.
diff --git a/sysctl.patch b/sysctl.patch
new file mode 100644
index 000000000000..14ac556cc37f
--- /dev/null
+++ b/sysctl.patch
@@ -0,0 +1,15 @@
+--- org/memory/mozjemalloc/jemalloc.c 2015-10-15 04:41:05.000000000 +0700
++++ work/memory/mozjemalloc/jemalloc.c 2020-09-03 22:47:42.138024901 +0700
+@@ -325,9 +325,9 @@
+ #endif
+ #include <sys/time.h>
+ #include <sys/types.h>
+-#if !defined(MOZ_MEMORY_SOLARIS) && !defined(MOZ_MEMORY_ANDROID)
+-#include <sys/sysctl.h>
+-#endif
++// #if !defined(MOZ_MEMORY_SOLARIS) && !defined(MOZ_MEMORY_ANDROID)
++// #include <sys/sysctl.h>
++// #endif
+ #include <sys/uio.h>
+ #ifndef MOZ_MEMORY
+ #include <sys/ktrace.h> /* Must come after several other sys/ includes. */