summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2020-09-02 15:43:42 +0800
committerSukanka2020-09-02 15:43:42 +0800
commitffa50173002726a95c395af1c9c32b26dd634515 (patch)
treec205542df460407216ebafe269f3c47332efd276
parenta21d5b6563b70386f9a0e5a63a1b0b53067d6fc2 (diff)
downloadaur-ffa50173002726a95c395af1c9c32b26dd634515.tar.gz
fix deps, arch and license
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
2 files changed, 30 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e654eb9db3a1..f77cc13256af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,24 @@
pkgbase = xunlei-bin
- pkgdesc = Xun lei download, 迅雷
+ pkgdesc = Xunlei download, 迅雷
pkgver = 1.0.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.xunlei.com/
arch = x86_64
- arch = arm64
- license = unknown
+ arch = aarch64
+ license = custom
+ depends = dbus-glib
+ depends = nodejs
+ depends = libxtst
+ depends = gtk2
+ depends = alsa-lib
+ depends = nss
+ depends = libxss
+ source = license.html::https://i.xunlei.com/xluser/privacy.html
+ sha512sums = 9164999cc42beb183ffbdd9b09441dac9af84a40593c781bce835fc93b4a0f835e161ab5fb55f8346d801f1bc071be4aff4408575d9ecd55e929120269e938fc
source_x86_64 = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.xunlei.download/com.xunlei.download_1.0.0.1_amd64.deb
sha512sums_x86_64 = e4957652d04188d960a04f969e1d31642ca9b421892de0b69c0623726ff3e9bc0095fff5f4037ad2e23d80becc2e91e6bc9dae5a4ba3121526ac6a8a8dc094c5
- source_arm64 = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.xunlei.download/com.xunlei.download_1.0.0.1_arm64.deb
- sha512sums_arm64 = 4e3ef94451c9fdbb1b8c6127108f5598c144801edca8f8347832c40a02858f11c9b04ebfe351ed72052f86016925f9d230cc2f002cc96d5c8b0062e9e7ce9314
+ source_aarch64 = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.xunlei.download/com.xunlei.download_1.0.0.1_arm64.deb
+ sha512sums_aarch64 = 4e3ef94451c9fdbb1b8c6127108f5598c144801edca8f8347832c40a02858f11c9b04ebfe351ed72052f86016925f9d230cc2f002cc96d5c8b0062e9e7ce9314
pkgname = xunlei-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7059ff985aaf..3f343d4a1206 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
pkgname=xunlei-bin
pkgver=1.0.0.1
-pkgrel=1
-pkgdesc="Xun lei download, 迅雷"
-arch=("x86_64" "arm64")
+pkgrel=2
+pkgdesc="Xunlei download, 迅雷"
+arch=("x86_64" "aarch64")
url="https://www.xunlei.com/"
-license=("unknown")
-depends=()
+license=("custom")
+depends=('dbus-glib' 'nodejs' 'libxtst' 'gtk2' 'alsa-lib' 'nss' 'libxss')
+
+source=("license.html::https://i.xunlei.com/xluser/privacy.html")
source_x86_64=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.xunlei.download/com.xunlei.download_${pkgver}_amd64.deb")
-source_arm64=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.xunlei.download/com.xunlei.download_${pkgver}_arm64.deb")
+source_aarch64=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.xunlei.download/com.xunlei.download_${pkgver}_arm64.deb")
+
+sha512sums=('9164999cc42beb183ffbdd9b09441dac9af84a40593c781bce835fc93b4a0f835e161ab5fb55f8346d801f1bc071be4aff4408575d9ecd55e929120269e938fc')
sha512sums_x86_64=(
'e4957652d04188d960a04f969e1d31642ca9b421892de0b69c0623726ff3e9bc0095fff5f4037ad2e23d80becc2e91e6bc9dae5a4ba3121526ac6a8a8dc094c5'
)
-sha512sums_arm64=(
+sha512sums_aarch64=(
'4e3ef94451c9fdbb1b8c6127108f5598c144801edca8f8347832c40a02858f11c9b04ebfe351ed72052f86016925f9d230cc2f002cc96d5c8b0062e9e7ce9314'
)
@@ -33,6 +37,10 @@ package(){
mkdir -p ${pkgdir}/usr/share/
mv opt/apps/com.xunlei.download/entries/icons ${pkgdir}/usr/share/icons
+ mv ${pkgdir}/usr/share/icons/hicolor/scalable/apps/com.thunder.download.svg \
+ ${pkgdir}/usr/share/icons/hicolor/scalable/apps/com.xunlei.download.svg
+
+ install -Dm644 license.html ${pkgdir}/usr/share/licenses/xunlei/license.html
sed -i '4c Exec=xunlei %U' ${pkgdir}/usr/share/applications/com.xunlei.download.desktop
sed -i '7c Categories=Network' ${pkgdir}/usr/share/applications/com.xunlei.download.desktop