summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-04-06 12:06:52 +0700
committerKonstantin Shalygin2019-04-06 12:06:52 +0700
commitdab2e9ca645bd3167448a64c63683b7143aa61bf (patch)
tree0c04e840a350f89c53b209eab496e900027891d8
parentdb7b7658b2ccaf973e8950a7f246042e73b64283 (diff)
downloadaur-dab2e9ca645bd3167448a64c63683b7143aa61bf.tar.gz
lua-json -> lua52-json
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3546d862891e..fff1ea3806ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jan 28 15:42:10 UTC 2017
+# Sat Apr 6 05:06:37 UTC 2019
pkgbase = xupnpd
pkgdesc = eXtensible UPnP agent (proxy IP TV multicast to DLNA)
pkgver = 1.033
- pkgrel = 5
+ pkgrel = 6
url = http://xupnpd.org
install = xupnpd.install
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = xupnpd
license = GPL2
makedepends = git
makedepends = lua
- makedepends = lua-luajson
+ makedepends = lua52-luajson
optdepends = udpxy: custom udp to http proxy
backup = var/lib/xupnpd/xupnpd.lua
source = xupnpd::git+https://github.com/clark15b/xupnpd
diff --git a/PKGBUILD b/PKGBUILD
index 720a408835b1..98ef7797048a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Konstantin Shalygin <k0ste@cn.ru>
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
# Contributor: Tomasz Maciej Nowak <com[dot]gmail[at]tmn505>
pkgname='xupnpd'
pkgdesc="eXtensible UPnP agent (proxy IP TV multicast to DLNA)"
pkgver='1.033'
-pkgrel='5'
+pkgrel='6'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
url="http://${pkgname}.org"
license=('GPL2')
-makedepends=('git' 'lua' 'lua-luajson')
+makedepends=('git' 'lua' 'lua52-luajson')
optdepends=('udpxy: custom udp to http proxy')
install="${pkgname}.install"
source=("${pkgname}::git+https://github.com/clark15b/${pkgname}"
@@ -35,17 +36,17 @@ build() {
package() {
cd ${srcdir}
- install -Dm644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
- install -Dm644 "sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -Dm0644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -Dm0644 "sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
cd "${pkgname}/src"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -dm755 -o 187 -g 187 "${pkgdir}/run/${pkgname}"
- install -dm755 -o 187 -g 187 "${pkgdir}/${_var}/config"
- install -dm755 -o 187 -g 187 "${pkgdir}/${_var}/localmedia"
- install -Dm644 -o 187 -g 187 *.lua -t "${pkgdir}/${_var}"
+ install -Dm0755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -dm0755 -o 187 -g 187 "${pkgdir}/run/${pkgname}"
+ install -dm0755 -o 187 -g 187 "${pkgdir}/${_var}/config"
+ install -dm0755 -o 187 -g 187 "${pkgdir}/${_var}/localmedia"
+ install -Dm0644 -o 187 -g 187 *.lua -t "${pkgdir}/${_var}"
cp -ax "playlists" "${pkgdir}/${_var}"
chown -R 187:187 "${pkgdir}/${_var}/playlists"
- install -dm755 "${pkgdir}/${_usr}"
+ install -dm0755 "${pkgdir}/${_usr}"
cp -ax "plugins" "${pkgdir}/${_usr}"
cp -ax "profiles" "${pkgdir}/${_usr}"
cp -ax "ui" "${pkgdir}/${_usr}"