summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2016-02-07 18:43:07 +0100
committerAdrian Freund2016-02-07 18:43:07 +0100
commit0ab0d66f687fcf805bbd8233d9542a76af278ea3 (patch)
treec6ec008ce4793caab8917f457310f0d2c4ccfc10
downloadaur-0ab0d66f687fcf805bbd8233d9542a76af278ea3.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30a4e5cb50f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 15:40:35 UTC 2016
+pkgbase = xuserrun-dbus-git
+ pkgdesc = Run commands as the currently-active X11 user while also using his dbus-session
+ pkgver = r6.de60127
+ pkgrel = 1
+ url = https://github.com/freundTech/xuserrun
+ arch = any
+ license = custom:UNLICENSE
+ makedepends = git
+ depends = systemd
+ provides = xuserrun
+ conflicts = xuserrun
+ source = xuserrun::git+https://github.com/freundTech/xuserrun.git
+ sha256sums = SKIP
+
+pkgname = xuserrun-dbus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4edbaf3af452
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Adrian Freund <freundadrian@gmail.com>
+_pkgname=xuserrun
+pkgname=$_pkgname-dbus-git
+pkgver=r7.e2b13c5
+pkgrel=1
+pkgdesc="Run commands as the currently-active X11 user while also using his dbus-session"
+arch=('any')
+url="https://github.com/freundTech/xuserrun"
+license=('custom:UNLICENSE')
+depends=('systemd')
+makedepends=('git')
+provides=('xuserrun')
+conflicts=('xuserrun')
+source=("$_pkgname::git+https://github.com/freundTech/xuserrun.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}