summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-12-08 22:20:00 +0800
committerChocobo12019-12-08 22:31:15 +0800
commitb2760a923bdac24b9418a33dab2caed1698240c8 (patch)
treec48b7f4c6dc2d7e9f51316fc2001466c7072df27
downloadaur-b2760a923bdac24b9418a33dab2caed1698240c8.tar.gz
newpkg: xvidcore-svn r2186-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bad3142cec2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xvidcore-svn
+ pkgdesc = High performance and high quality MPEG-4 video codec
+ pkgver = r2186
+ pkgrel = 1
+ url = https://www.xvid.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = subversion
+ makedepends = nasm
+ depends = glibc
+ provides = xvidcore
+ conflicts = xvidcore
+ options = staticlibs
+
+pkgname = xvidcore-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c7dc3efee7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=xvidcore-svn
+pkgver=r2186
+pkgrel=1
+pkgdesc="High performance and high quality MPEG-4 video codec"
+arch=('i686' 'x86_64')
+url="https://www.xvid.com/"
+license=('GPL2')
+depends=('glibc')
+makedepends=('subversion' 'nasm')
+provides=('xvidcore')
+conflicts=('xvidcore')
+options=('staticlibs')
+#source=("svn+http://anonymous:@svn.xvid.org/trunk")
+#sha256sums=('SKIP')
+
+
+prepare() {
+ svn checkout http://svn.xvid.org/trunk --username anonymous --password ""
+}
+
+pkgver() {
+ cd "trunk"
+
+ _ver="$(svnversion)"
+ printf "r%s" "${_ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "trunk/xvidcore/build/generic"
+
+ ./bootstrap.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+package() {
+ cd "trunk/xvidcore/build/generic"
+
+ make DESTDIR="$pkgdir" install
+}