summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornate2016-05-04 20:14:21 -0700
committernate2016-05-04 20:14:21 -0700
commit73ea626978ae4b16a14d35d02793af310aa6f15f (patch)
tree16bdb9c368175007f3780c18a3765fdf5dfc66ad
downloadaur-73ea626978ae4b16a14d35d02793af310aa6f15f.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a7574006401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu May 5 03:13:21 UTC 2016
+pkgbase = xviewer-plugins
+ pkgdesc = Plugins for xviewer. X-Apps Project.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/linuxmint/xviewer-plugins
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gnome-common
+ depends = xviewer
+ depends = libpeas
+ conflicts = xviewer-plugins-git
+ source = https://github.com/linuxmint/xviewer-plugins/archive/1.0.2.tar.gz
+ md5sums = 3d0190f278a0ce813ebad730218523d9
+
+pkgname = xviewer-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..101c14f975a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Nate Simon <aurpkg (at natesimon.net)>
+
+pkgname=xviewer-plugins
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Plugins for xviewer. X-Apps Project."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('xviewer' 'libpeas')
+makedepends=('gnome-common')
+provides=($_pkgname)
+conflicts=('xviewer-plugins-git')
+url='https://github.com/linuxmint/xviewer-plugins'
+
+source=("https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('3d0190f278a0ce813ebad730218523d9')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./autogen.sh --prefix="/usr" \
+ --localstatedir="/var" \
+ --libexecdir="/usr/lib/xviewer-plugins"
+ make
+}
+
+package(){
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}
+