summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-10-02 22:14:45 +0200
committerMarcin Wieczorek2016-10-02 22:14:45 +0200
commit152e66f729f8e941f0e42fec64c499666cf19c42 (patch)
tree548e56f721f8cb3cfc38184cbdf49f6ad7326c59
parent5ce540a5f7280042b96a4cc59e157a44e42ca348 (diff)
downloadaur-152e66f729f8e941f0e42fec64c499666cf19c42.tar.gz
Fix build error (2.5.1-2)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD50
-rw-r--r--xvst.install11
3 files changed, 28 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac46060f520c..ba2f62d9c127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,8 @@
-# Generated by makepkg 4.2.1
-# Thu Jun 11 21:38:27 UTC 2015
pkgbase = xvst
pkgdesc = GUI tool for downloading videos from sites like YouTube, GoogleVideo etc.
pkgver = 2.5.1
- pkgrel = 1
+ pkgrel = 2
url = http://xviservicethief.sourceforge.net
- install = xvst.install
arch = i686
arch = x86_64
license = GPL3
@@ -15,7 +12,8 @@ pkgbase = xvst
depends = qt5-webkit
depends = qt5-script
optdepends = flvstreamer: for downloading flv files.
- source = xvst-2.5.1.tar.gz::https://github.com/xVST/xVideoServiceThief/archive/2.5.1.tar.gz
+ source = https://github.com/xVST/xVideoServiceThief/archive/2.5.1.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/xVST/xVideoServiceThief/pull/14.patch
source = xvst.desktop
source = beeg.patch
source = chilloutzone.patch
@@ -25,6 +23,7 @@ pkgbase = xvst
source = sunporno.patch
source = wat.tv.patch
md5sums = 917d32b75585eec0e0ff5245253f33ed
+ md5sums = 3cf071f9d97c6c3ed32103b67866b668
md5sums = 9d4d4d4841b497fe64705d36e7955174
md5sums = 417c1a8cec359835e25ba8ed89cb86c6
md5sums = d9bf2659bba5c99f885e9febdb3d4d2e
diff --git a/PKGBUILD b/PKGBUILD
index f9cc8a6f1fe6..4475fd4ea17a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=xvst
_pkgname=xVideoServiceThief
pkgver=2.5.1
-pkgrel=1
+pkgrel=2
pkgdesc='GUI tool for downloading videos from sites like YouTube, GoogleVideo etc.'
url='http://xviservicethief.sourceforge.net'
license=('GPL3')
@@ -14,9 +14,9 @@ arch=('i686' 'x86_64')
depends=('ffmpeg' 'qt5-webkit' 'qt5-script')
makedepends=('sed' 'qt5-tools')
optdepends=('flvstreamer: for downloading flv files.')
-install=xvst.install
-source=("$pkgname-$pkgver.tar.gz::https://github.com/xVST/xVideoServiceThief/archive/${pkgver}.tar.gz"
- 'xvst.desktop'
+source=("https://github.com/xVST/xVideoServiceThief/archive/${pkgver}.tar.gz"
+ "https://patch-diff.githubusercontent.com/raw/xVST/xVideoServiceThief/pull/14.patch"
+ 'xvst.desktop'
'beeg.patch'
'chilloutzone.patch'
'disable_update.patch'
@@ -25,6 +25,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/xVST/xVideoServiceThief/arc
'sunporno.patch'
'wat.tv.patch')
md5sums=('917d32b75585eec0e0ff5245253f33ed'
+ '3cf071f9d97c6c3ed32103b67866b668'
'9d4d4d4841b497fe64705d36e7955174'
'417c1a8cec359835e25ba8ed89cb86c6'
'd9bf2659bba5c99f885e9febdb3d4d2e'
@@ -34,27 +35,29 @@ md5sums=('917d32b75585eec0e0ff5245253f33ed'
'e353efa41a386887cf3f76c0bf9350af'
'29adc4b5a9326202478dd41fc3d3c199')
-build()
-{
- cd ${_pkgname}-${pkgver}
+prepare() {
+ cd ${_pkgname}-${pkgver}
# Patches provided by getdeb.net. Add/fix download sites and turns off
# automatic updates.
for i in "${srcdir}"/*.patch; do
- patch -p1 < "$i"
+ patch -p1 < "${i}"
done
# Fix path names and end-of-line encoding.
sed -i "s|getApplicationPath()\ +\ \"|\"/usr/share/${pkgname}|g" src/options.cpp
sed -i 's/\r//' "how to compile.txt"
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
# Creat translation files.
lrelease-qt5 resources/translations/*.ts
rm -f resources/translations/template_for_new_translations.qm
qmake-qt5 -set build_mode dynamic_build
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS+="${CFLAGS}" QMAKE_CXXFLAGS+="${CXXFLAGS}" \
- CONFIG+=release -o Makefile xVideoServiceThief.pro
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS+="${CFLAGS}" QMAKE_CXXFLAGS+="${CXXFLAGS}" CONFIG+=release -o Makefile xVideoServiceThief.pro
make
}
@@ -62,23 +65,18 @@ package()
{
cd ${_pkgname}-${pkgver}
- install -d -m 0755 "$pkgdir"/usr/share/$pkgname/{plugins,languages}
- find resources/services -name "*.js" \
- -exec cp -dpR {} "$pkgdir"/usr/share/$pkgname/plugins \;
- install -m 0644 resources/translations/*.qm \
- "$pkgdir"/usr/share/$pkgname/languages
- install -m 0644 resources/translations/definitions/*.language \
- "$pkgdir"/usr/share/$pkgname/languages
- find "$pkgdir"/usr/share/$pkgname/ -type f -exec chmod 0644 '{}' \;
- install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -d -m 0755 "${pkgdir}/usr/share/${pkgname}/"{plugins,languages}
+ find resources/services -name "*.js" -exec cp -dpR {} "${pkgdir}/usr/share/${pkgname}/plugins" \;
+ install -m 0644 resources/translations/*.qm "${pkgdir}/usr/share/${pkgname}/languages"
+ install -m 0644 resources/translations/definitions/*.language "${pkgdir}/usr/share/${pkgname}/languages"
+ find "${pkgdir}/usr/share/${pkgname}/" -type f -exec chmod 0644 '{}' \;
+ install -Dm755 bin/${pkgname} "$pkgdir/usr/bin/${pkgname}"
- install -Dm644 "$srcdir"/xvst.desktop \
- "$pkgdir"/usr/share/applications/$pkgname.desktop
- install -Dm644 resources/images/InformationLogo.png \
- "$pkgdir"/usr/share/pixmaps/$pkgname.png
+ install -Dm644 "${srcdir}/xvst.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 resources/images/InformationLogo.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D -m644 "GPL.txt" "${pkgdir}/usr/share/licenses/${pkgname}/GPL.txt"
- install -d -m 0755 "$pkgdir"/usr/share/doc/$pkgname
+ install -d -m 0755 "${pkgdir}/usr/share/doc/${pkgname}"
cp -a "how to compile.txt" README.md resources/{changelog.txt,service_list.html} \
- "$pkgdir"/usr/share/doc/$pkgname
+ "${pkgdir}/usr/share/doc/${pkgname}"
}
-
diff --git a/xvst.install b/xvst.install
deleted file mode 100644
index e111ef946053..000000000000
--- a/xvst.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}