summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsputnick2015-06-19 00:09:12 +0200
committersputnick2015-06-19 00:09:12 +0200
commit5e88f7d75a1653b74169e86a0c3859824d7be267 (patch)
tree8a6aa4568ce2bdaf0235fe8d1c23429840fbcb08
downloadaur-5e88f7d75a1653b74169e86a0c3859824d7be267.tar.gz
Initial xwax-jack commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a99dcb0ffa9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = xwax-jack
+ pkgdesc = Open-source digital vinyl emulation software.
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.xwax.co.uk/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = sdl
+ makedepends = sdl_ttf
+ depends = ttf-dejavu
+ depends = alsa-lib
+ depends = jack
+ optdepends = oggdeg: for OGG import
+ optdepends = faad: for AAC import
+ optdepends = cdparanoia: for CD import
+ optdepends = mpg123: for MP3 import
+ optdepends = flac: for FLAC import
+ optdepends = ffmpeg: for video fallback import
+ provides = xwax
+ conflicts = xwax
+ source = http://www.xwax.co.uk/releases/xwax-1.4.tar.gz
+ md5sums = 01afde1f1222fca38eab736e0b3df116
+
+pkgname = xwax-jack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e68bdfced941
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Mainteneur: sputnick <gilles DOT quenot AT gmail DOT com>
+# Contributor: cryptocrack <archlinux AT cryptocrack DOT de>
+pkgname=xwax-jack
+_ownedpkgname=xwax
+pkgver=1.5
+pkgrel=1
+pkgdesc="Open-source digital vinyl emulation software."
+arch=('i686' 'x86_64')
+url="http://www.xwax.co.uk/"
+license="GPL"
+depends=('ttf-dejavu' 'alsa-lib' 'jack')
+makedepends=('sdl' 'sdl_ttf')
+optdepends=(
+ "oggdeg: for OGG import"
+ "faad: for AAC import"
+ "cdparanoia: for CD import"
+ "mpg123: for MP3 import"
+ "flac: for FLAC import"
+ "ffmpeg: for video fallback import"
+)
+provides=('xwax')
+conflicts=('xwax')
+
+source=(http://www.xwax.co.uk/releases/$_ownedpkgname-$pkgver.tar.gz)
+md5sums=('7c2f30c3a9a71c4dba107e3eb9b40430')
+
+build() {
+ cd $startdir/src/$_ownedpkgname-$pkgver
+
+ # Patching rig.c to use default Archlinux rtprio value ( see /etc/security/limits.conf )
+ sed -i 's/^#define REALTIME_PRIORITY 80/#define REALTIME_PRIORITY 65/' ./rig.c
+
+ ./configure '--enable-alsa' '--enable-jack' '--prefix /usr'
+ make PREFIX=$pkgdir/usr EXECDIR=$pkgdir/usr/share/${pkgname} || return 1
+}
+
+package() {
+ cd $startdir/src/$_ownedpkgname-$pkgver
+ make EXECDIR=$pkgdir/usr/share/${pkgname} PREFIX=$pkgdir/usr install || return 1
+}
+
+# vim:ts=4:sw=4