summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2018-08-06 22:39:33 +0200
committerKarol Babioch2018-08-06 22:39:33 +0200
commit81517e70d440689b1718af654c7e6158fff825d4 (patch)
tree4bd1f69da7969a2484f34ff912e52e537be58175
downloadaur-81517e70d440689b1718af654c7e6158fff825d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76f87c63fc18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xwmfs
+ pkgdesc = X11 Window-Manager file system based on FUSE
+ pkgver = 0.82
+ pkgrel = 1
+ url = https://github.com/gerstner-hub/xwmfs
+ arch = x86_64
+ license = GPL2
+ depends = fuse
+ source = git+https://github.com/gerstner-hub/xwmfs.git#tag=v0.82
+ sha256sums = SKIP
+
+pkgname = xwmfs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56c6a48ec535
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*.tar.gz
+/*.tar.gz.sig
+/*.tar.xz
+/pkg/
+/src/
+/xwmfs/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..258dfb6cd213
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Karol Babioch <karol@babioch.de
+
+pkgname=xwmfs
+pkgver=0.82
+pkgrel=1
+pkgdesc=" X11 Window-Manager file system based on FUSE"
+arch=('x86_64')
+url="https://github.com/gerstner-hub/xwmfs"
+license=('GPL2')
+depends=('fuse')
+source=("git+https://github.com/gerstner-hub/xwmfs.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./bootstrap
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
+