summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2018-08-06 22:51:44 +0200
committerKarol Babioch2018-08-06 22:51:44 +0200
commitb84c4014fc15f24714f487a6df29f99cf3ad26e5 (patch)
tree83b6e13b47df6f91001d8a780688779d8ae51e77
downloadaur-b84c4014fc15f24714f487a6df29f99cf3ad26e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78059135e5d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xwmfs-git
+ pkgdesc = X11 Window-Manager file system based on FUSE
+ pkgver = 0.82.r0.gdf2b3c5
+ pkgrel = 1
+ url = https://github.com/gerstner-hub/xwmfs
+ arch = x86_64
+ license = GPL2
+ depends = fuse
+ source = git+https://github.com/gerstner-hub/xwmfs.git#tag=v0.82.r0.gdf2b3c5
+ sha256sums = SKIP
+
+pkgname = xwmfs-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56c6a48ec535
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*.tar.gz
+/*.tar.gz.sig
+/*.tar.xz
+/pkg/
+/src/
+/xwmfs/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ba48f8b5cef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Karol Babioch <karol@babioch.de
+
+pkgname=xwmfs-git
+pkgver=0.82.r0.gdf2b3c5
+pkgrel=1
+pkgdesc="X11 Window-Manager file system based on FUSE"
+arch=('x86_64')
+url="https://github.com/gerstner-hub/xwmfs"
+license=('GPL2')
+depends=('fuse')
+source=("git+https://github.com/gerstner-hub/xwmfs.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/xwmfs"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/xwmfs"
+ ./bootstrap
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/xwmfs"
+ make DESTDIR="${pkgdir}" install
+}
+