summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2019-01-03 11:40:45 +0100
committerFabioLolix2019-01-03 11:40:45 +0100
commit3b344d978984572cc11a9745bd6f33d3fc722fcc (patch)
tree31bed0b20c0d9572d23d14af4556f2acb265d9c3
parent3e8b86061bb29b34554291d45384eb93661699c8 (diff)
downloadaur-3b344d978984572cc11a9745bd6f33d3fc722fcc.tar.gz
v8.0.1658 + revision
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
2 files changed, 37 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eb26cb6b0ff..e3b13ff5510e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = xxd-standalone
pkgdesc = Hexdump utility from vim
- pkgver = 8.0.0055
+ pkgver = 8.0.1658
pkgrel = 1
url = http://www.vim.org
- arch = i686
arch = x86_64
- license = MIT
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL2
+ license = custom: MIT-X11
depends = glibc
provides = xxd
- conflicts = vim
- conflicts = gvim
- source = https://raw.githubusercontent.com/vim/vim/v8.0.0055/src/xxd/xxd.c
- source = https://raw.githubusercontent.com/vim/vim/v8.0.0055/runtime/doc/xxd.1
- source = LICENSE
- md5sums = fbbe3afbc7bdd8f8c6b75f8789292bab
- md5sums = 25af84984b44a69ab4f72710a209a00a
+ conflicts = xxd
+ source = xxd-8.0.1658.c::https://raw.githubusercontent.com/vim/vim/v8.0.1658/src/xxd/xxd.c
+ source = https://raw.githubusercontent.com/vim/vim/v8.0.1658/runtime/doc/xxd.1
+ source = xxd-standalone-Makefile::https://raw.githubusercontent.com/vim/vim/master/src/xxd/Makefile
+ source = https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/xxd-LICENSE
+ md5sums = 304e675b808e350c63f412a145eb3e68
+ md5sums = 87467fa59b7efa85002baa2d78d2c0bb
+ md5sums = d551525508580302c1c22a9ec0c0fb84
md5sums = 533619562b1da5fd32458517fc740af8
pkgname = xxd-standalone
diff --git a/PKGBUILD b/PKGBUILD
index 0890c0740f1d..981ba6c06868 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,36 @@
-# Maintainer: Daniel Greve <greve.daniel.l@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Daniel Greve <greve.daniel.l@gmail.com>
pkgname=xxd-standalone
-pkgver=8.0.0055
+pkgver=8.0.1658
pkgrel=1
-pkgdesc='Hexdump utility from vim'
-arch=('i686' 'x86_64')
+pkgdesc="Hexdump utility from vim"
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='http://www.vim.org'
-license=('MIT' 'GPL2')
-provides=('xxd')
-conflicts=('vim' 'gvim')
-depends=('glibc')
-source=("https://raw.githubusercontent.com/vim/vim/v${pkgver}/src/xxd/xxd.c"
+license=(GPL2 "custom: MIT-X11") # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776191
+provides=(xxd)
+conflicts=(xxd)
+depends=(glibc)
+source=("xxd-${pkgver}.c::https://raw.githubusercontent.com/vim/vim/v${pkgver}/src/xxd/xxd.c"
"https://raw.githubusercontent.com/vim/vim/v${pkgver}/runtime/doc/xxd.1"
- 'LICENSE')
-md5sums=('fbbe3afbc7bdd8f8c6b75f8789292bab'
- '25af84984b44a69ab4f72710a209a00a'
+ "$pkgname-Makefile::https://raw.githubusercontent.com/vim/vim/master/src/xxd/Makefile"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/xxd-LICENSE")
+md5sums=('304e675b808e350c63f412a145eb3e68'
+ '87467fa59b7efa85002baa2d78d2c0bb'
+ 'd551525508580302c1c22a9ec0c0fb84'
'533619562b1da5fd32458517fc740af8')
+# check versions at https://github.com/vim/vim/tree/master/src/xxd
+
+prepare() {
+ mv xxd-${pkgver}.c xxd.c
+}
build() {
- ## https://github.com/vim/vim/blob/master/src/xxd/Makefile
- cc -DUNIX -o xxd xxd.c
+ make -f $pkgname-Makefile
}
package() {
install -Dm755 xxd "${pkgdir}/usr/bin/xxd"
install -Dm644 xxd.1 "${pkgdir}/usr/share/man/man1/xxd.1"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/xxd/LICENSE"
+ install -Dm644 xxd-LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}