summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Greve2016-11-02 05:58:42 -0400
committerDaniel Greve2016-11-02 05:58:42 -0400
commit3e8b86061bb29b34554291d45384eb93661699c8 (patch)
tree28bc14e496e91d2373e815cd40cca4c75fd48d6d
downloadaur-3e8b86061bb29b34554291d45384eb93661699c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE10
-rw-r--r--PKGBUILD29
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eb26cb6b0ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xxd-standalone
+ pkgdesc = Hexdump utility from vim
+ pkgver = 8.0.0055
+ pkgrel = 1
+ url = http://www.vim.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = GPL2
+ depends = glibc
+ provides = xxd
+ conflicts = vim
+ conflicts = gvim
+ source = https://raw.githubusercontent.com/vim/vim/v8.0.0055/src/xxd/xxd.c
+ source = https://raw.githubusercontent.com/vim/vim/v8.0.0055/runtime/doc/xxd.1
+ source = LICENSE
+ md5sums = fbbe3afbc7bdd8f8c6b75f8789292bab
+ md5sums = 25af84984b44a69ab4f72710a209a00a
+ md5sums = 533619562b1da5fd32458517fc740af8
+
+pkgname = xxd-standalone
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5522463f9b44
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,10 @@
+(c) 1990-1998 by Juergen Weigert (jnweiger@informatik.uni-erlangen.de)
+
+I hereby grant permission to distribute and use xxd
+under X11-MIT or GPL-2.0 (at the user's choice).
+
+Small changes made afterwards by Bram Moolenaar et al.
+
+Distribute freely and credit me,
+make money and share with me,
+lose money and don't ask me.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0890c0740f1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Greve <greve.daniel.l@gmail.com>
+
+pkgname=xxd-standalone
+pkgver=8.0.0055
+pkgrel=1
+pkgdesc='Hexdump utility from vim'
+arch=('i686' 'x86_64')
+url='http://www.vim.org'
+license=('MIT' 'GPL2')
+provides=('xxd')
+conflicts=('vim' 'gvim')
+depends=('glibc')
+source=("https://raw.githubusercontent.com/vim/vim/v${pkgver}/src/xxd/xxd.c"
+ "https://raw.githubusercontent.com/vim/vim/v${pkgver}/runtime/doc/xxd.1"
+ 'LICENSE')
+md5sums=('fbbe3afbc7bdd8f8c6b75f8789292bab'
+ '25af84984b44a69ab4f72710a209a00a'
+ '533619562b1da5fd32458517fc740af8')
+
+build() {
+ ## https://github.com/vim/vim/blob/master/src/xxd/Makefile
+ cc -DUNIX -o xxd xxd.c
+}
+
+package() {
+ install -Dm755 xxd "${pkgdir}/usr/bin/xxd"
+ install -Dm644 xxd.1 "${pkgdir}/usr/share/man/man1/xxd.1"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/xxd/LICENSE"
+}