summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryparitcher2019-05-15 11:05:47 -0400
committeryparitcher2019-05-15 11:05:47 -0400
commit5f7ce021cda4189f74dfa7bc98c794c258cde85d (patch)
tree72372db39a7b16c179a4a9de257f83ba66b266a7
parentcca34ecb329282ef9da501f674f9e6cbcbb46ab5 (diff)
downloadaur-5f7ce021cda4189f74dfa7bc98c794c258cde85d.tar.gz
update to version 5.0 based on qt5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
-rw-r--r--cpp11.diff14
3 files changed, 37 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6c91b9da8eb..7a3a1f5f11e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xxdiff
pkgdesc = A graphical browser for file and directory differences.
- pkgver = 4.0
- pkgrel = 3
+ pkgver = 5.0
+ pkgrel = 1
url = https://bitbucket.org/blais/xxdiff
arch = x86_64
arch = i686
@@ -10,9 +10,11 @@ pkgbase = xxdiff
makedepends = bison
makedepends = mercurial
makedepends = python-docutils
- depends = qt4
- source = hg+https://bitbucket.org/blais/xxdiff#revision=ae1e62c
+ depends = qt5-base
+ source = hg+https://bitbucket.org/blais/xxdiff#revision=5e5f885
+ source = cpp11.diff
md5sums = SKIP
+ md5sums = feb486afc64fa53cfc348219d3779d41
pkgname = xxdiff
diff --git a/PKGBUILD b/PKGBUILD
index 65117de6c348..da4539a5c472 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
# Contributor: tyr0 <thomas.hoernes@gmx.at>
-# Maintainer: Daniel YC Lin <dlin.tw at gmail>
+# Contributor: Daniel YC Lin <dlin.tw at gmail>
+# Maintainer: Y Paritcher <y.archlinux@paritcher.com>
+
pkgname=xxdiff
-pkgver=4.0
-pkgrel=3
+pkgver=5.0
+pkgrel=1
pkgdesc="A graphical browser for file and directory differences."
-#url="http://furius.ca/xxdiff"
url="https://bitbucket.org/blais/xxdiff"
license=('GPL2')
-depends=('qt4')
+depends=('qt5-base')
makedepends=('flex>=2.5.31' 'bison' 'mercurial' 'python-docutils')
arch=('x86_64' 'i686')
-source=("hg+https://bitbucket.org/blais/xxdiff#revision=ae1e62c")
-md5sums=('SKIP')
-#source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2")
-#md5sums=('4025fe852ea408adbfa70ec77d09efc9')
+source=("hg+https://bitbucket.org/blais/xxdiff#revision=5e5f885" "cpp11.diff")
+md5sums=('SKIP'
+ 'feb486afc64fa53cfc348219d3779d41')
+
+prepare() {
+ cd "xxdiff/src"
+ # Debian C++11 Patch
+ patch -N -i ../../cpp11.diff
+}
+
build() {
cd "$pkgname/src"
- export QMAKE=/usr/bin/qmake-qt4
make -f Makefile.bootstrap
make
}
@@ -24,4 +30,5 @@ build() {
package() {
cd "$pkgname"
install -D -m 755 "bin/xxdiff" "$pkgdir/usr/bin/xxdiff"
+ install -D -m 644 "src/xxdiff.1" "$pkgdir/usr/share/man/man1/xxdiff.1"
}
diff --git a/cpp11.diff b/cpp11.diff
new file mode 100644
index 000000000000..3daea408f126
--- /dev/null
+++ b/cpp11.diff
@@ -0,0 +1,14 @@
+Description: building against Qt5 requires at least C++11
+Author: Florian Schlichting <fsfs@debian.org>
+
+--- a/src/xxdiff.pro
++++ b/src/xxdiff.pro
+@@ -111,7 +111,7 @@
+ #linux-g++:QMAKE_LIBS += -lmpatrol -lbfd -liberty
+
+ # auto_ptr deprecated in C++11, removed in C++17
+-linux: QMAKE_CXXFLAGS += -std=c++03
++linux: QMAKE_CXXFLAGS += -std=c++11
+
+ #----------------------------------------
+ # Max OS X with XFree86 port, macx-g++