summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Bazile2021-05-08 20:49:00 +0200
committerRomain Bazile2021-05-08 20:49:00 +0200
commit4dd8a6e890fbbb9e9138ca7b3aed46edbade3b9a (patch)
tree7da7b7e83187db0fb3c8f78c0f93ace98d697193
parentab098e9e8d2227d40c52b266ab7a2687214cf621 (diff)
downloadaur-4dd8a6e890fbbb9e9138ca7b3aed46edbade3b9a.tar.gz
addition of CMakelists.patch to fix compilation with openjpeg2.4
-rw-r--r--.SRCINFO4
-rw-r--r--CMakelists.txt.patch23
-rw-r--r--PKGBUILD8
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc1c5a093316..5e01bc00f88a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xygrib
pkgdesc = Grib reader and weather visualization software. Zygrib fork.
pkgver = 1.2.6.1
- pkgrel = 2
+ pkgrel = 3
url = https://opengribs.org/
arch = x86_64
arch = aarch64
@@ -20,9 +20,11 @@ pkgbase = xygrib
source = https://github.com/opengribs/XyGrib/archive/v1.2.6.1.tar.gz
source = xygrib.install
source = skewt.patch
+ source = CMakelists.txt.patch
sha1sums = 8e3431ed6a5ef114d77ac57029129a26a381f696
sha1sums = 97eec7e40bd2d4f44986ffbf5096ac4ba37ebbfe
sha1sums = 1fa4cf6b72863c9f33a80946d9f4afe7f855df6a
+ sha1sums = 9fc7839f3fa38b7855ee5a165f7148162aba39bf
pkgname = xygrib
diff --git a/CMakelists.txt.patch b/CMakelists.txt.patch
new file mode 100644
index 000000000000..00812061162d
--- /dev/null
+++ b/CMakelists.txt.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b066a04..0e286f2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -108,17 +108,12 @@
+ ~/Library/Frameworks/include
+ /Library/Frameworks/include
+ /usr/local/include
+- /usr/local/include/openjpeg-2.3
+- /usr/include/openjpeg-2.3
+- /usr/local/include/openjpeg-2.1
+- /usr/include/openjpeg-2.1
+- /usr/local/include/openjpeg-2.2
+- /usr/include/openjpeg-2.2
+ /usr/include
+ /sw/include # Fink
+ /opt/local/include # DarwinPorts
+ /opt/csw/include # Blastwave
+ /opt/include
++ PATH_SUFFIXES openjpeg-2.4 openjpeg-2.3 openjpeg-2.2 openjpeg-2.1
+ REQUIRED
+ )
+ include_directories(${OPENJPEG_INCLUDE_DIR})
diff --git a/PKGBUILD b/PKGBUILD
index 6ff2cef5f158..b57715a43478 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xygrib
pkgver=1.2.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="Grib reader and weather visualization software. Zygrib fork."
arch=('x86_64' 'aarch64')
license=("GPL3")
@@ -13,15 +13,17 @@ conflicts=('xygrib-git')
depends=('libnova' 'qwt' 'proj' 'qt5-base' 'openjpeg2')
makedepends=('cmake' 'zlib' 'bzip2' 'libpng')
url="https://opengribs.org/"
-source=("https://github.com/opengribs/XyGrib/archive/v$pkgver.tar.gz" "xygrib.install" "skewt.patch")
+source=("https://github.com/opengribs/XyGrib/archive/v$pkgver.tar.gz" "xygrib.install" "skewt.patch" "CMakelists.txt.patch")
sha1sums=('8e3431ed6a5ef114d77ac57029129a26a381f696'
'97eec7e40bd2d4f44986ffbf5096ac4ba37ebbfe'
- '1fa4cf6b72863c9f33a80946d9f4afe7f855df6a')
+ '1fa4cf6b72863c9f33a80946d9f4afe7f855df6a'
+ '9fc7839f3fa38b7855ee5a165f7148162aba39bf')
build() {
cd $srcdir/XyGrib-$pkgver
patch --strip=1 -i $srcdir/skewt.patch
+ patch --strip=1 -i $srcdir/CMakelists.txt.patch
mkdir -p build
cd build
cmake ../