summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:34:01 +0900
committerDaichi Shinozaki2015-06-09 18:34:01 +0900
commite5080b2b00904f933488925466f73610b0f5ab42 (patch)
tree6d633c80e9d932399f501be39e8a53c6ee4760de
downloadaur-e5080b2b00904f933488925466f73610b0f5ab42.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21d1a49295c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xyzsh
+ pkgdesc = Interactive shell and text processing tools
+ pkgver = 1.5.8
+ pkgrel = 2
+ url = https://github.com/ab25cq/xyzsh
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = oniguruma
+ depends = gc
+ source = http://dl.sourceforge.jp/xyzsh/60140/xyzsh-1.5.8.tgz
+ md5sums = 4fab43dbd794fb4af871ac6c9989526b
+
+pkgname = xyzsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df74d543a14f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: noonov <noonov@gmail.com>
+
+pkgname=xyzsh
+pkgver=1.5.8
+pkgrel=2
+pkgdesc="Interactive shell and text processing tools"
+arch=('i686' 'x86_64')
+url="https://github.com/ab25cq/xyzsh"
+license=('MIT')
+depends=('oniguruma' 'gc')
+source=(http://dl.sourceforge.jp/xyzsh/60140/${pkgname}-${pkgver}.tgz)
+md5sums=('4fab43dbd794fb4af871ac6c9989526b')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr --sysconfdir=/etc --with-optimize
+ make -j1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make -j1 DESTDIR=${pkgdir} install
+ install --mode=644 -D --no-target-directory $srcdir/$pkgname-$pkgver/LICENSE "$pkgdir"/usr/share/$pkgname/LICENSE
+
+}
+