summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRX142019-08-25 17:00:27 +0100
committerRX142019-08-25 17:04:40 +0100
commit6f62967c1702b18fe04f8cf53df88fb2c55873b6 (patch)
tree7348f806085434eec1da09e21ad2b2c8060b0535
downloadaur-6f62967c1702b18fe04f8cf53df88fb2c55873b6.tar.gz
xz-static 5.2.4-1
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a97434bef924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xz-static
+ pkgdesc = Statically linked library and command line tools for XZ and LZMA compressed files
+ pkgver = 5.2.4
+ pkgrel = 1
+ url = https://tukaani.org/xz/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = custom
+ depends = sh
+ options = staticlibs
+ source = https://tukaani.org/xz/xz-5.2.4.tar.gz
+ source = https://tukaani.org/xz/xz-5.2.4.tar.gz.sig
+ validpgpkeys = 3690C240CE51B4670D30AD1C38EE757D69184620
+ md5sums = 5ace3264bdd00c65eeec2891346f65e6
+ md5sums = SKIP
+
+pkgname = xz-static
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..958dc5ba3edc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed954bac09e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Stephanie Wilde-Hobbs <steph@rx14.co.uk>
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: François Charette <firmicus@gmx.net>
+
+pkgname=xz-static
+pkgver=5.2.4
+pkgrel=1
+pkgdesc='Statically linked library and command line tools for XZ and LZMA compressed files'
+arch=('x86_64')
+url='https://tukaani.org/xz/'
+license=('GPL' 'LGPL' 'custom')
+depends=('sh')
+options=('staticlibs')
+source=("https://tukaani.org/xz/xz-${pkgver}.tar.gz"{,.sig})
+md5sums=('5ace3264bdd00c65eeec2891346f65e6'
+ 'SKIP')
+validpgpkeys=('3690C240CE51B4670D30AD1C38EE757D69184620')
+
+build() {
+ cd ${srcdir}/xz-${pkgver}
+
+ ./configure --prefix=/usr \
+ --disable-rpath \
+ --enable-werror \
+ --disable-shared \
+ --disable-xz \
+ --disable-xzdec \
+ --disable-lzmadec \
+ --disable-lzmainfo \
+ --disable-scripts \
+ --disable-doc
+ make
+}
+
+check() {
+ cd ${srcdir}/xz-${pkgver}
+ make check
+}
+
+package() {
+ cd ${srcdir}/xz-${pkgver}
+ make DESTDIR=${pkgdir} install
+
+ rm -Rf ${pkgdir}/usr/{bin,include,share,lib/pkgconfig}
+}