summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGnucco2015-06-21 15:58:05 +0200
committerGnucco2015-06-21 15:58:05 +0200
commitb30ef927b026b24ebeade3f7caf01be3d07c2eb2 (patch)
tree021f8485a1b94527a033e6bf664717086e7f35ca
downloadaur-b30ef927b026b24ebeade3f7caf01be3d07c2eb2.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50650780112a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xzoom
+ pkgdesc = a screen magnifier
+ pkgver = 0.3
+ pkgrel = 4
+ url = ftp://sunsite.unc.edu/pub/linux/libs/X/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = imake
+ depends = libxt
+ depends = libxext
+ source = ftp://sunsite.unc.edu/pub/linux/libs/X/xzoom-0.3.tgz
+ source = ftp://ftp.acc.umu.se/mirror/cdimage/snapshot/Debian/pool/main/x/xzoom/xzoom_0.3-23.diff.gz
+ md5sums = c6ecc5fade34cf46cbe8c00b93d7ac78
+ md5sums = d3a397e24aba7025f94e264fea0906d0
+
+pkgname = xzoom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54ca9f92cbe4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: pezcurrel <pezcurrel [at] tiscali.it>
+# Contributor: Thomas Karmann <thomas [at] krmnn.de>
+
+pkgname=xzoom
+pkgver=0.3
+pkgrel=4
+pkgdesc="a screen magnifier"
+arch=('i686' 'x86_64')
+url="ftp://sunsite.unc.edu/pub/linux/libs/X/"
+license=('GPL')
+depends=('libxt' 'libxext')
+makedepends=('imake')
+source=(ftp://sunsite.unc.edu/pub/linux/libs/X/$pkgname-$pkgver.tgz
+ ftp://ftp.acc.umu.se/mirror/cdimage/snapshot/Debian/pool/main/x/xzoom/xzoom_0.3-23.diff.gz)
+md5sums=('c6ecc5fade34cf46cbe8c00b93d7ac78' 'd3a397e24aba7025f94e264fea0906d0')
+build() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 < "$srcdir/xzoom_0.3-23.diff"
+ xmkmf
+ sed -i "s@-O2@$CFLAGS@" ./Makefile
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install install.man
+}