summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-19 17:22:43 +0800
committerzxp198210052024-01-19 17:22:43 +0800
commitba47b535802c87f94dd57036f455e9b93b2f5989 (patch)
tree094069262fe73b3f29007ecf31a59fd214692517
parent4b96fa21e5e71fedd690819197b43c88119fe3fb (diff)
downloadaur-ba47b535802c87f94dd57036f455e9b93b2f5989.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--y2mp3.sh13
3 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3da36f9fb9c..9df0116e9219 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = y2mp3-bin
pkgdesc = An Electron app to download youtube playlist
pkgver = 2.5.9
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/moshfeu/y2mp3
arch = x86_64
license = MIT
makedepends = squashfuse
depends = electron17
depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = y2mp3-2.5.9
conflicts = y2mp3
source = y2mp3-2.5.9.AppImage::https://github.com/moshfeu/y2mp3/releases/download/v2.5.9/y2mp3-2.5.9.AppImage
@@ -21,6 +18,6 @@ pkgbase = y2mp3-bin
source = y2mp3.sh
sha256sums = 70e8686444ed77589bcfde74609f92aedf775a0dcd4528da71cfb5b341ad282f
sha256sums = e38ba30feb86e7387a43e735f2b65cf072436b3af6b3333abb4e6c460e6622fe
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = y2mp3-bin
diff --git a/PKGBUILD b/PKGBUILD
index 196c51fb0dc7..825fbf60d9ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=y2mp3-bin
pkgver=2.5.9
_electronversion=17
-pkgrel=3
+pkgrel=4
pkgdesc="An Electron app to download youtube playlist"
arch=('x86_64')
url="https://github.com/moshfeu/y2mp3"
@@ -12,12 +12,9 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -29,7 +26,7 @@ source=(
)
sha256sums=('70e8686444ed77589bcfde74609f92aedf775a0dcd4528da71cfb5b341ad282f'
'e38ba30feb86e7387a43e735f2b65cf072436b3af6b3333abb4e6c460e6622fe'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -37,7 +34,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g;s|Music|AudioVideo|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g;s|Music|AudioVideo|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {
diff --git a/y2mp3.sh b/y2mp3.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/y2mp3.sh
+++ b/y2mp3.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file