summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Geiler2024-09-13 13:18:43 +0200
committerJonas Geiler2024-09-13 13:18:43 +0200
commitdb18450a3de909316b5745026f276f0ed795ab8e (patch)
tree1f0c62571def21f087d80e8898a4cab3e93074fe
parent9e2472704126b6a535716ee5e840baea1f748456 (diff)
downloadaur-db18450a3de909316b5745026f276f0ed795ab8e.tar.gz
chore: added .nvchecker.toml for easier version bumps
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD4
3 files changed, 8 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 1d65adf6de3a..32777f0abb61 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*
!PKGBUILD
!.SRCINFO
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..b90aa3201f07
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[yaak]
+source = "github"
+github = "yaakapp/app"
+use_latest_release = true
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index 8681a050bada..2ea1d5d3eea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,8 +36,8 @@ options=(
!emptydirs # Remove empty directories from package because why not
)
source=(
- "yaak::git+https://github.com/yaakapp/app#tag=v${pkgver}"
- "yaak-plugins::git+https://github.com/yaakapp/plugins#commit=${_plugins_commit}"
+ "yaak::git+https://github.com/yaakapp/app.git#tag=v${pkgver}"
+ "yaak-plugins::git+https://github.com/yaakapp/plugins.git#commit=${_plugins_commit}"
# TODO: Use license from yaak repo after next release
"${pkgname}-${pkgver}.LICENSE::https://raw.githubusercontent.com/yaakapp/app/master/LICENSE"
)