summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuten Ye2015-06-24 14:38:16 +0800
committerGuten Ye2015-06-24 14:38:16 +0800
commit3feeda59ce38832201586547720be9f67ad68f57 (patch)
tree037369031e4a506af7d6558cf5f5721b5006e464
downloadaur-3feeda59ce38832201586547720be9f67ad68f57.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD33
-rw-r--r--apache.example.conf15
-rw-r--r--nginx.example.conf7
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e65cf944c883
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = yaaw-git
+ pkgdesc = Yet Another Aria2 Web Frontend in pure HTML/CSS/Javascirpt. PKGBUILD source code at https://github.com/gutenye/aurs/tree/master/yaaw-git
+ pkgver = r124.a5d2d30
+ pkgrel = 1
+ url = https://github.com/binux/yaaw
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = yaaw
+ conflicts = yaaw
+ source = yaaw-git::git://github.com/binux/yaaw.git
+ source = apache.example.conf
+ source = nginx.example.conf
+ md5sums = SKIP
+ md5sums = 6bcbdb5390332f13e3bc5c6cbf5524c7
+ md5sums = a04cf9b8610507f54505487a15b411cc
+
+pkgname = yaaw-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..28fa04fc4565
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+yaaw-git/
+src/
+pkg/
+*.tar.*
+*.tgz
+*.gem
+*.deb
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6caf7bf6846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname="yaaw-git"
+pkgver=r124.a5d2d30
+pkgrel=1
+pkgdesc="Yet Another Aria2 Web Frontend in pure HTML/CSS/Javascirpt. PKGBUILD source code at https://github.com/gutenye/aurs/tree/master/$pkgname"
+arch=("i686" "x86_64")
+url="https://github.com/binux/yaaw"
+license=("GPL")
+makedepends=("git")
+provides=("yaaw")
+conflicts=("yaaw")
+source=(
+ "$pkgname::git://github.com/binux/yaaw.git"
+ "apache.example.conf"
+ "nginx.example.conf")
+md5sums=('SKIP'
+ '6bcbdb5390332f13e3bc5c6cbf5524c7'
+ 'a04cf9b8610507f54505487a15b411cc')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/yaaw"
+ mkdir -p "$pkgdir/etc/webapps/yaaw"
+ cp -r * "$pkgdir/usr/share/webapps/yaaw"
+ cp ../*.example.conf "$pkgdir/etc/webapps/yaaw"
+ chown http:http -R "$pkgdir/usr/share/webapps/yaaw"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..3a20bd750dfd
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,15 @@
+<IfModule alias_module>
+ Alias /yaaw /usr/share/webapps/yaaw
+ <Directory "/usr/share/webapps/yaaw">
+ AllowOverride None
+ Options None
+ Order allow,deny
+ #Allow from all
+ Allow from 127.0.0.1 localhost
+
+ #AuthType Basic
+ #AuthName "Restricted Files"
+ #AuthUserFile htpasswd
+ #Require user foo
+ </Directory>
+</IfModule>
diff --git a/nginx.example.conf b/nginx.example.conf
new file mode 100644
index 000000000000..46b012cbbd73
--- /dev/null
+++ b/nginx.example.conf
@@ -0,0 +1,7 @@
+location /yaaw/ {
+ allow 127.0.0.1;
+ deny all;
+
+ #auth_basic "Restricted";
+ #auth_basic_user_file htpasswd;
+}