summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-08-27 12:23:48 +0200
committerGustavo Alvarez2016-08-27 12:23:48 +0200
commitdebca27b1bda96d6f26915f8a10bf0748264fcff (patch)
tree654d93f742ec17e928a13e40f2d80b192666f241
downloadaur-debca27b1bda96d6f26915f8a10bf0748264fcff.tar.gz
Initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD65
-rw-r--r--rwx.patch20
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca29f4b86621
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Sat Aug 27 10:23:47 UTC 2016
+pkgbase = yabause-qt5-git
+ pkgdesc = A Sega Saturn emulator. Qt5 port (GIT version)
+ pkgver = 0.9.15.r3231.ee28cc7
+ pkgrel = 1
+ url = http://yabause.org
+ arch = x86_64
+ arch = i386
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = glu
+ makedepends = doxygen
+ depends = mini18n-git
+ depends = openal
+ depends = sdl2
+ depends = glew
+ depends = freeglut
+ depends = libxkbcommon-x11
+ depends = qt5-multimedia
+ depends = libsm
+ provides = yabause-qt5
+ conflicts = yabause-qt
+ conflicts = yabause-qt5
+ conflicts = yabause-gtk
+ conflicts = yabause
+ source = git+https://github.com/Yabause/yabause.git
+ source = rwx.patch
+ sha1sums = SKIP
+ sha1sums = 749276456a137ab913c631b9c61d113d7b67c854
+
+pkgname = yabause-qt5-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00ddf57ab937
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!rwx.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d720a8d7d881
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Harley Laue <losinggeneration@gmail.com>
+# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Anton Shestakov <engoredi@ya.ru>
+# Contributor: Tiago Camargo <tcamargo@gmail.com>
+# Contributor: robb_force <robb_force@holybuffalo.net>
+
+pkgname=yabause-qt5-git
+pkgver=0.9.15.r3231.ee28cc7
+pkgrel=1
+pkgdesc="A Sega Saturn emulator. Qt5 port (GIT version)"
+arch=('x86_64' 'i386')
+url='http://yabause.org'
+license=('GPL')
+depends=('mini18n-git'
+ 'openal'
+ 'sdl2'
+ 'glew'
+ 'freeglut'
+ 'libxkbcommon-x11'
+ 'qt5-multimedia'
+ 'libsm'
+ )
+makedepends=('git'
+ 'cmake'
+ 'glu'
+ 'doxygen'
+ )
+conflicts=('yabause-qt' 'yabause-qt5' 'yabause-gtk' 'yabause')
+provides=('yabause-qt5')
+source=('git+https://github.com/Yabause/yabause.git'
+ 'rwx.patch'
+ )
+sha1sums=('SKIP'
+ '749276456a137ab913c631b9c61d113d7b67c854'
+ )
+
+pkgver() {
+ cd yabause/yabause
+ _ver="$(cat CMakeLists.txt | grep -m3 "YAB_VERSION" | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+ cd yabause/yabause
+ patch -Np1 -i "${srcdir}/rwx.patch"
+}
+
+build() {
+ cd build
+
+ cmake ../yabause/yabause \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DYAB_PORTS=qt \
+ -DYAB_NETWORK=ON \
+ -DYAB_OPTIMIZED_DMA=ON
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/rwx.patch b/rwx.patch
new file mode 100644
index 000000000000..bb0491b373f8
--- /dev/null
+++ b/rwx.patch
@@ -0,0 +1,20 @@
+--- a/src/sh2_dynarec/linkage_x64.s 2013-03-11 20:29:53.112870900 +0100
++++ b/src/sh2_dynarec/linkage_x64.s 2013-03-11 20:31:48.856778600 +0100
+@@ -747,3 +747,7 @@ breakpoint:
+ ret
+ /* Set breakpoint here for debugging */
+ .size breakpoint, .-breakpoint
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- a/src/sh2_dynarec/linkage_x86.s 2013-03-11 20:30:08.157693100 +0100
++++ b/src/sh2_dynarec/linkage_x86.s 2013-03-11 20:32:30.993310600 +0100
+@@ -743,3 +743,7 @@ breakpoint:
+ ret
+ /* Set breakpoint here for debugging */
+ .size breakpoint, .-breakpoint
++
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif