summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreomanis2019-04-13 21:28:07 +0200
committereomanis2019-04-13 21:28:07 +0200
commit1cc2e178e64db311504bc2482a7befcee8c92b01 (patch)
tree2a187bb0b2f8a1e5ef6a24c9ecd2ec505bc6cca6
downloadaur-1cc2e178e64db311504bc2482a7befcee8c92b01.tar.gz
Initial commit, yabddnsd 0.6.0
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f771b924f484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = yabddnsd
+ pkgdesc = DNS record updater for freedns.afraid.org domains written in bash
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://eomanis.mooo.com/permshare/yabddnsd/index.xhtml
+ arch = any
+ license = GPL3
+ depends = bash>=4.4
+ depends = grep
+ depends = sed
+ depends = wget
+ depends = bind-tools
+ depends = coreutils
+ depends = iproute2
+ depends = bc
+ optdepends = miniupnpc: Detection of public IPv4 address using UPnP
+ replaces = freedns-maintain-ip
+ source = http://eomanis.mooo.com/permshare/yabddnsd/yabddnsd-0.6.0.tar.gz
+ sha384sums = 41907cd9c4f75c05a4e90943b2867fcb6029d95ab08b92dc5efb518caff59ac6cb3c4d995f1c1028291e46844ef56ce2
+
+pkgname = yabddnsd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..daa57388a683
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: eomanis at web dot de
+
+pkgname='yabddnsd'
+_pkgverUpstream="0.6.0"
+pkgver="${_pkgverUpstream//-/.}"
+pkgrel=1
+pkgdesc="DNS record updater for freedns.afraid.org domains written in bash"
+arch=('any')
+url='http://eomanis.mooo.com/permshare/yabddnsd/index.xhtml'
+license=('GPL3')
+depends=('bash>=4.4' 'grep' 'sed' 'wget' 'bind-tools' 'coreutils' 'iproute2' 'bc')
+optdepends=('miniupnpc: Detection of public IPv4 address using UPnP')
+replaces=('freedns-maintain-ip')
+source=("http://eomanis.mooo.com/permshare/yabddnsd/yabddnsd-${_pkgverUpstream}.tar.gz")
+sha384sums=('41907cd9c4f75c05a4e90943b2867fcb6029d95ab08b92dc5efb518caff59ac6cb3c4d995f1c1028291e46844ef56ce2')
+
+package() {
+
+ srcRootDir="${srcdir}/${pkgname}-${_pkgverUpstream}"
+
+ # Place the main bash script into /usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ cp -t . "${srcRootDir}/yabddnsd"
+ chmod u=rwx,go=rx "yabddnsd"
+
+ # Place the systemd unit file into /usr/lib/systemd/system
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ cd "${pkgdir}/usr/lib/systemd/system"
+ cp -t . "${srcRootDir}/yabddnsd@.service"
+ chmod u=rw,go=r "yabddnsd@.service"
+
+ # Gzip and place the manual page
+ mkdir -p "${pkgdir}/usr/share/man"
+ cd "${pkgdir}/usr/share/man"
+ mkdir "man8"
+ gzip --fast --to-stdout - < "${srcRootDir}/yabddnsd.8" > "man8/yabddnsd.8.gz"
+ chmod -R u=rwX,go=rX .
+}