summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2020-05-29 19:03:24 +0200
committerRobbert van der Helm2020-05-29 19:03:24 +0200
commit0d5e7b49ae832b8b08665b873bd29ff44b7b8584 (patch)
treef3874dee8f52c9e0fdde392de136e14573a0a658
parentd0b39e8bee1f663970a4916c0ac7a47d83ff4975 (diff)
downloadaur-0d5e7b49ae832b8b08665b873bd29ff44b7b8584.tar.gz
Update for 1.2.0 and build from source
Using the binary releases is much more convenient and they work just fine on Arch/Manjaro, but the regular AUR convention is that only `*-bin` packages use prebuilt binaries. There's now a `yabridge-bin` package that uses the binaries from the GitHub releases section just like this package did in the past.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 839e3235eaf2..0a56be921bfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = yabridge
pkgdesc = Yet Another VST bridge, run Windows VST2 plugins under Linux
- pkgver = 1.1.4
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
arch = x86_64
license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = boost
+ makedepends = lib32-boost-libs>=1.72.0
depends = wine
depends = libxcb
depends = lib32-libxcb
- source = https://github.com/robbert-vdh/yabridge/releases/download/1.1.4/yabridge-1.1.4.tar.gz
- sha256sums = f5ee3371c8e66dd6169a59eb05bb57ceb94244ea27083c49c47cabfedcc022e5
+ source = https://github.com/robbert-vdh/yabridge/archive/1.2.0.tar.gz
+ sha256sums = c620fb2e96227ebcb148d0f55121d1519a8f570a3c58b3bc9b0151920fb7d556
pkgname = yabridge
diff --git a/PKGBUILD b/PKGBUILD
index cd7dd3ba4922..f9eff00062de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Robbert van der Helm <mail@robbertvanderhelm.nl>
pkgname=yabridge
-pkgver=1.1.4
+pkgver=1.2.0
pkgrel=1
pkgdesc="Yet Another VST bridge, run Windows VST2 plugins under Linux"
epoch=
@@ -9,17 +9,27 @@ arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
license=('GPL3')
depends=('wine' 'libxcb' 'lib32-libxcb')
-makedepends=()
+makedepends=('meson' 'ninja' 'boost' 'lib32-boost-libs>=1.72.0')
install=yabridge.install
-source=("https://github.com/robbert-vdh/yabridge/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('f5ee3371c8e66dd6169a59eb05bb57ceb94244ea27083c49c47cabfedcc022e5')
+source=("https://github.com/robbert-vdh/yabridge/archive/$pkgver.tar.gz")
+sha256sums=('c620fb2e96227ebcb148d0f55121d1519a8f570a3c58b3bc9b0151920fb7d556')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # If you don't want to build lib32-boost-libs and you don't need the 32-bit
+ # bitbridge, then you can leave out the dependency for it and set the
+ # `use-bitbridge` option to false.
+ meson setup --buildtype=release --cross-file cross-wine.conf -Duse-bitbridge=true build
+ ninja -C build
+}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname-$pkgver/build"
install -dm755 "${pkgdir}"/usr/bin
- install yabridge-host.exe{,.so} "${pkgdir}"/usr/bin
- install yabridge-host-32.exe{,.so} "${pkgdir}"/usr/bin
+ install yabridge-{host,group}.exe{,.so} "${pkgdir}"/usr/bin
+ install yabridge-{host,group}-32.exe{,.so} "${pkgdir}"/usr/bin
install -dm755 "${pkgdir}"/usr/lib
install libyabridge.so "${pkgdir}"/usr/lib