summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-02-16 19:55:18 +0100
committerRobbert van der Helm2021-02-16 19:55:34 +0100
commit690d0b20d5e1e1ce0e2d624427ab64b91948fab4 (patch)
tree0f0beb1361cf81b1352d29203e4b5f4855871005
parent5d19f7578aafbf49351aff4acdc4bc8f0f76798b (diff)
downloadaur-690d0b20d5e1e1ce0e2d624427ab64b91948fab4.tar.gz
Work around issue with Brazilian locales
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90e75ca8bdcc..7541bf29869a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,7 +53,10 @@ build() {
# The unity build takes can take up to 2 GB of RAM per target, so if the
# system does not have enough RAM to build everything at once we'll limit the
# number of concurrent jobs
- total_memory=$(free --gibi --si | awk '/^Mem:/ { print $2 }')
+ #
+ # NOTE: The `LANG=C` is needed because apparently the `pt_BR.UTF-8` locale
+ # changes `Mem:` to `Mem.:`, so who knows what other locales might do
+ total_memory=$(env LANG=C free --gibi --si | awk '/^Mem:/ { print $2 }')
if [ "$total_memory" -le 4 ]; then
echo -e "\n$total_memory gigabytes of RAM detected, limiting the number of build jobs to 1\n"
ninja -C build -j1