summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-12-20 21:07:59 +0100
committerRobbert van der Helm2021-12-20 21:08:10 +0100
commitad9ce8dea1ad9b7458cba4f5e3c537c82cd1238d (patch)
tree5319d009ffca2bf92d4cfca7a206e95d92757123
parent968986ff000e772fbf5420102cc60a9be63c4836 (diff)
downloadaur-ad9ce8dea1ad9b7458cba4f5e3c537c82cd1238d.tar.gz
Use bitsery, function2 and tomlplusplus from repos
These have now been packaged, and lib32-boost-libs is now also in multilib.
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ad3e70a17ba..0598d8b3b287 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yabridge
pkgdesc = A modern and transparent way to use Windows VST2 and VST3 plugins on Linux
pkgver = 3.7.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
arch = x86_64
@@ -9,13 +9,19 @@ pkgbase = yabridge
makedepends = git
makedepends = meson
makedepends = ninja
+ makedepends = cmake
depends = wine
depends = boost
+ depends = bitsery
+ depends = function2
depends = libxcb
- depends = lib32-boost-libs>=1.72.0
+ depends = tomlplusplus
+ depends = lib32-boost-libs
depends = lib32-libxcb
optdepends = yabridgectl: utility for setting up and managing yabridge
source = https://github.com/robbert-vdh/yabridge/archive/3.7.0.tar.gz
+ source = use-repo-dependencies.patch::https://github.com/robbert-vdh/yabridge/compare/5f08d989d6686c9094d960df131e34cd41879215..4cbcf79a8479bba9b13b6e5324dad568815e1d7d.patch
sha256sums = 8ba302e68636cce8ede171f3b6497050814edefcd1d2591ce629e0f109ebc396
+ sha256sums = c97fefa01d888e8b6f3519a10d6d2b27b3dc8c89e074d1fe6c2d80b4b98e9056
pkgname = yabridge
diff --git a/.gitignore b/.gitignore
index 9f41572a64a4..e93356b0f3f7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
src/
pkg/
+*.patch
*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 815fcc43f896..19abc5c05e28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,25 @@
pkgname=yabridge
pkgver=3.7.0
-pkgrel=4
+pkgrel=5
pkgdesc="A modern and transparent way to use Windows VST2 and VST3 plugins on Linux"
arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
license=('GPL3')
-depends=('wine' 'boost' 'libxcb' 'lib32-boost-libs>=1.72.0' 'lib32-libxcb')
+depends=('wine' 'boost' 'bitsery' 'function2' 'libxcb' 'tomlplusplus' 'lib32-boost-libs' 'lib32-libxcb')
optdepends=('yabridgectl: utility for setting up and managing yabridge')
-makedepends=('git' 'meson' 'ninja')
+makedepends=('git' 'meson' 'ninja' 'cmake')
install=yabridge.install
-source=("https://github.com/robbert-vdh/yabridge/archive/$pkgver.tar.gz")
-sha256sums=('8ba302e68636cce8ede171f3b6497050814edefcd1d2591ce629e0f109ebc396')
+source=("https://github.com/robbert-vdh/yabridge/archive/$pkgver.tar.gz"
+ "use-repo-dependencies.patch::https://github.com/robbert-vdh/yabridge/compare/5f08d989d6686c9094d960df131e34cd41879215..4cbcf79a8479bba9b13b6e5324dad568815e1d7d.patch")
+sha256sums=('8ba302e68636cce8ede171f3b6497050814edefcd1d2591ce629e0f109ebc396'
+ 'c97fefa01d888e8b6f3519a10d6d2b27b3dc8c89e074d1fe6c2d80b4b98e9056')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch --strip=1 --input="$srcdir/use-repo-dependencies.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"