summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-02-14 17:57:39 +0100
committerRobbert van der Helm2021-02-14 17:57:56 +0100
commite8ffd3f97a6f73cfc919746a0bcf91971ac95ae1 (patch)
treeb1f765f87c4fe32084ae41cd3a982f8f05dfce9c
parentf544eb7276ac680c5c257071ee46ad062b8ad084 (diff)
downloadaur-e8ffd3f97a6f73cfc919746a0bcf91971ac95ae1.tar.gz
Add a warning for Wine 6.2
The build won't succeed under Wine 6.2 because one of the headers is now invalid C++.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efd77cec16fa..bc8707d6dc38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yabridge
pkgdesc = A modern and transparent way to use Windows VST2 and VST3 plugins on Linux
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index acae0b2ae1a2..191e1c12fc0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=yabridge
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A modern and transparent way to use Windows VST2 and VST3 plugins on Linux"
arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
@@ -18,6 +18,23 @@ sha256sums=('693bc7b2650bc6fc59fa95a724b2cc41e2b26e94614a2d3b0ce53454e411f58d')
build() {
cd "$pkgname-$pkgver"
+ # TODO: Once this has been fixed upstream, we can remove the warning again
+ wine_version=$(wine --version | grep --only-matching -E '[0-9]+\.[0-9.]+' | head -n1)
+ if [[ $wine_version == 6.2* ]]; then
+ echo "#"
+ echo "# WARNING: Wine 6.2 has a regression that will cause build errors when"
+ echo "# compiling yabridge because the headers are no longer valid in"
+ echo "# C++. The build will likely fail. Either temporarily downgrade"
+ echo "# to a Wine 6.1 version or use the 'yabridge-bin' AUR package"
+ echo "# instead until this is fixed."
+ echo "#"
+ echo "# Continuing in five seconds..."
+ echo "#"
+
+ # Or else the message will be very easy to miss
+ sleep 5
+ fi
+
# Meson won't apply any new options or update wraps if they already exist, so
# if we're building from a dirty src/ directory we'll just nuke any cached
# files