summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2020-07-17 15:31:32 +0200
committerRobbert van der Helm2020-07-17 15:31:32 +0200
commit1f958d9daf7dd78fc08703ea3fcf558203f3638c (patch)
treeb5820ebbdf7a6ebd8df0c55b7c0ee099fbf290d6
parent0985aaabcf648bba61d63ad94ad0e0b46456ae7e (diff)
downloadaur-1f958d9daf7dd78fc08703ea3fcf558203f3638c.tar.gz
Update for yabridge 1.3.0
This package now includes yabridgectl.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--yabridge.install6
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50e194840bc0..ea0a54e28766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yabridge-bin
pkgdesc = Yet Another VST bridge, run Windows VST2 plugins under Linux
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
@@ -10,9 +10,13 @@ pkgbase = yabridge-bin
depends = libxcb
depends = lib32-libxcb
provides = yabridge
+ provides = yabridgectl
conflicts = yabridge
- source = https://github.com/robbert-vdh/yabridge/releases/download/1.2.1/yabridge-1.2.1.tar.gz
- sha256sums = 4fc71fb0598637553d553de158ca610fd24ed02b1143756968952084c78aef92
+ conflicts = yabridgectl-git
+ source = https://github.com/robbert-vdh/yabridge/releases/download/1.3.0/yabridge-1.3.0.tar.gz
+ source = https://github.com/robbert-vdh/yabridge/releases/download/1.3.0/yabridgectl-1.3.0.tar.gz
+ sha256sums = 60a5820acfb3bd49ee23abc91461347cf93150592cb33d3c0fbec328c461e264
+ sha256sums = f60cbebaee618f7fc6abe2e3d311c6acb8fca76d6306567a5b1a6b699287d1bc
pkgname = yabridge-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5efce479df6e..322019655efd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=yabridge-bin
_pkgname=yabridge
-pkgver=1.2.1
+_yabridgectl=yabridgectl
+pkgver=1.3.0
pkgrel=1
pkgdesc="Yet Another VST bridge, run Windows VST2 plugins under Linux"
epoch=
@@ -11,11 +12,13 @@ url="https://github.com/robbert-vdh/yabridge"
license=('GPL3')
depends=('wine' 'libxcb' 'lib32-libxcb')
makedepends=()
-provides=('yabridge')
-conflicts=('yabridge')
+provides=('yabridge' 'yabridgectl')
+conflicts=('yabridge' 'yabridgectl-git')
install=yabridge.install
-source=("https://github.com/robbert-vdh/yabridge/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz")
-sha256sums=('4fc71fb0598637553d553de158ca610fd24ed02b1143756968952084c78aef92')
+source=("https://github.com/robbert-vdh/yabridge/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz"
+ "https://github.com/robbert-vdh/yabridge/releases/download/$pkgver/$_yabridgectl-$pkgver.tar.gz")
+sha256sums=('60a5820acfb3bd49ee23abc91461347cf93150592cb33d3c0fbec328c461e264'
+ 'f60cbebaee618f7fc6abe2e3d311c6acb8fca76d6306567a5b1a6b699287d1bc')
package() {
cd "$srcdir/$_pkgname"
@@ -25,6 +28,10 @@ package() {
install -dm755 "${pkgdir}"/usr/lib
install libyabridge.so "${pkgdir}"/usr/lib
+
+ # Also include yabridgectl
+ cd "$srcdir/$_yabridgectl"
+ install yabridgectl "${pkgdir}"/usr/bin
}
# vim:set ts=2 sw=2 et:
diff --git a/yabridge.install b/yabridge.install
index f4d106a020e3..f34dec34eab7 100644
--- a/yabridge.install
+++ b/yabridge.install
@@ -1,7 +1,7 @@
post_upgrade() {
cat <<EOF
-If you are upgrading from a previous version of yabridge and you have made
-copies of 'libyabridge.so', then you should not forget to replace those copies
-with new ones.
+If you are upgrading from a previous version of yabridge and you are using the
+copy-based installation method, then don't forget to run 'yabridgectl sync' to
+update those copies.
EOF
}