summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2020-05-05 15:13:33 +0200
committerRobbert van der Helm2020-05-05 15:29:55 +0200
commit063f44d066ef696012f694a18c0b160767b01503 (patch)
tree35719c44ebc0a4c132cb93aa21253976213d68a5
downloadaur-063f44d066ef696012f694a18c0b160767b01503.tar.gz
Add a PKGBUILD for yabridge-git
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD45
-rw-r--r--yabridge.install7
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d07a9089c924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = yabridge-git
+ pkgdesc = Yet Another VST bridge, run Windows VST2 plugins under Linux
+ pkgver = 1.0.0.r23.g8049385
+ pkgrel = 1
+ url = https://github.com/robbert-vdh/yabridge
+ install = yabridge.install
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = boost
+ makedepends = lib32-boost-libs
+ depends = wine
+ depends = libxcb
+ depends = lib32-libxcb
+ provides = yabridge
+ conflicts = yabridge
+ source = git+https://github.com/robbert-vdh/yabridge
+ sha256sums = SKIP
+
+pkgname = yabridge-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4435031f84d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src/
+pkg/
+yabridge/
+
+*.tar.gz
+*.tar.xz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3541b42daed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Robbert van der Helm <mail@robbertvanderhelm.nl>
+
+pkgname=yabridge-git
+_pkgname=yabridge
+pkgver=1.0.0.r23.g8049385
+pkgrel=1
+pkgdesc="Yet Another VST bridge, run Windows VST2 plugins under Linux"
+arch=('x86_64')
+url="https://github.com/robbert-vdh/yabridge"
+license=('GPL3')
+depends=('wine' 'libxcb' 'lib32-libxcb')
+makedepends=('meson' 'ninja' 'boost' 'lib32-boost-libs')
+provides=('yabridge')
+conflicts=('yabridge')
+install='yabridge.install'
+source=('git+https://github.com/robbert-vdh/yabridge')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+
+ # If you don't want to build lib32-boost-libs and you don't need the 32-bit
+ # bitbridge, then you can leave out the dependency for it and set the
+ # `use-bitbridge` option to false.
+ meson setup --buildtype=release --cross-file cross-wine.conf -Duse-bitbridge=true build
+ ninja -C build
+}
+
+package() {
+ cd "$_pkgname/build"
+
+ install -dm755 "${pkgdir}"/usr/bin
+ install yabridge-host.exe{,.so} "${pkgdir}"/usr/bin
+ install yabridge-host-32.exe{,.so} "${pkgdir}"/usr/bin
+
+ install -dm755 "${pkgdir}"/usr/lib
+ install libyabridge.so "${pkgdir}"/usr/lib
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/yabridge.install b/yabridge.install
new file mode 100644
index 000000000000..f4d106a020e3
--- /dev/null
+++ b/yabridge.install
@@ -0,0 +1,7 @@
+post_upgrade() {
+ cat <<EOF
+If you are upgrading from a previous version of yabridge and you have made
+copies of 'libyabridge.so', then you should not forget to replace those copies
+with new ones.
+EOF
+}