summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2020-06-08 16:09:10 +0200
committerRobbert van der Helm2020-06-08 16:09:10 +0200
commitb72c5cfde141be64a05671b9eee1f2c9feef8955 (patch)
treec94bbe47a70d8f34dc2efd0f0bd9abf4dc61d7da
parent782a4dc9bc9af4f758bd68c3717e31d5dce1503c (diff)
downloadaur-b72c5cfde141be64a05671b9eee1f2c9feef8955.tar.gz
Use the new build options
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21a8a0074261..6c2690788582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=yabridge-git
_pkgname=yabridge
-pkgver=1.2.0.r0.g150106e
+pkgver=1.2.0.r15.gc4842cc
pkgrel=1
pkgdesc="Yet Another VST bridge, run Windows VST2 plugins under Linux"
arch=('x86_64')
@@ -27,7 +27,15 @@ build() {
# If you don't want to build lib32-boost-libs and you don't need the 32-bit
# bitbridge, then you can leave out the dependency for it and set the
# `use-bitbridge` option to false.
- meson setup --buildtype=release --cross-file cross-wine.conf -Duse-bitbridge=true build
+ options=(--buildtype=release -Dwith-bitbridge=true)
+
+ # Meson won't apply any new options when this is not a clean build
+ if [[ -d build ]]; then
+ meson setup --reconfigure "${options[@]}" build
+ else
+ meson setup --cross-file cross-wine.conf "${options[@]}" build
+ fi
+
ninja -C build
}