summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Corona2016-02-24 19:12:11 -0600
committerAlberto Corona2016-02-24 19:12:11 -0600
commita7975dd9674eb42071dee4243870eb1af25cca57 (patch)
tree8402612b6ad274f6677450baa33dc6fcd4c7daea
downloadaur-yabs-git.tar.gz
Initial commit
Signed-off-by: Alberto Corona <ac@albertocorona.com>
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c11dd2baafe1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Feb 25 01:12:01 UTC 2016
+pkgbase = yabs-git
+ pkgdesc = Yet another build system
+ pkgver = 0.1.0.rs.36.g26a628c
+ pkgrel = 1
+ url = https://github.com/0X1A/yabs
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = cargo
+ makedepends = rust
+ provides = yabs
+ conflicts = yabs
+ source = git+https://github.com/0X1A/yabs.git
+ md5sums = SKIP
+
+pkgname = yabs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..801ff2400b70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Author: Alberto Corona <ac@albertocorona.com>
+
+pkgname=yabs-git
+pkgver=0.1.0.rs.36.g26a628c
+pkgrel=1
+pkgdesc="Yet another build system"
+arch=("any")
+url="https://github.com/0X1A/yabs"
+license=('BSD')
+makedepends=('git' 'cargo' 'rust')
+provides=('yabs')
+conflicts=('yabs')
+source=('git+https://github.com/0X1A/yabs.git')
+md5sums=('SKIP')
+_gitname=yabs
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ cargo build --release -j2
+}
+
+package() {
+ cd $_gitname
+ install -d $pkgdir/usr/bin
+ install -m755 $srcdir/yabs/target/release/yabs $pkgdir/usr/bin/yabs
+}