summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2019-08-02 02:18:52 -0300
committerMarcos Heredia2019-08-02 02:18:52 -0300
commit752f591d2a449e045dd73187f1ad3d54bff1c312 (patch)
tree85e6cc540b85e0f029e9ca3e73aba553b1333b85
parent03907c2fed65385b5b74b1dba8560a328c095b76 (diff)
downloadaur-752f591d2a449e045dd73187f1ad3d54bff1c312.tar.gz
Update 1.7.0-1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD15
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c20d0bd5c3d7..a5a3fdab464c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by makepkg 5.0.1
-# Tue Apr 25 13:07:22 UTC 2017
pkgbase = yacas
pkgdesc = Yet another computer algebra system
- pkgver = 1.6.1
+ pkgver = 1.7.0
pkgrel = 1
url = http://www.yacas.org/
install = yacas.install
@@ -14,22 +12,32 @@ pkgbase = yacas
makedepends = cmake
makedepends = perl
makedepends = python-sphinx
- depends = glibc
- depends = gcc-libs
- depends = qt5-base
- depends = qt5-webkit
- depends = qt5-svg
+ makedepends = python-sphinxcontrib-bibtex
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ makedepends = npm
+ depends = dbus
+ depends = libbluray
+ depends = libva
+ depends = libvorbis
+ depends = libxcursor
+ depends = nspr
+ depends = qt5-webengine
+ depends = x264
+ depends = x265
+ depends = xvidcore
+ depends = zstd
optdepends = gnuplot
optdepends = lynx
optdepends = texmacs
optdepends = fbreader: Reading EPUB manual
conflicts = yagy
noextract = yacas.epub
- source = yacas-1.6.1.tar.gz::https://github.com/grzegorzmazur/yacas/archive/v1.6.1.tar.gz
+ source = yacas-1.7.0.tar.gz::https://github.com/grzegorzmazur/yacas/archive/v1.7.0.tar.gz
source = https://media.readthedocs.org/epub/yacas/v1.6.1/yacas.epub
source = yacas.desktop
source = yacas-docs.desktop
- md5sums = c955d95b2eee79a59b6df5a2002814de
+ md5sums = cd91867dba8aa858643d4bb9777f608c
md5sums = 1278f790a15792996931c2adc56dd8aa
md5sums = eb776002fabe21623716ed2642f6d365
md5sums = 04d2a47c02fba5d88f337a404e02929c
diff --git a/PKGBUILD b/PKGBUILD
index 2949a95f0c34..d482b66f9b11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@
# Maintainer : Marcos Heredia <chelqo@gmail.com>
pkgname=yacas
-pkgver=1.6.1
+pkgver=1.7.0
+_docver=1.6.1
pkgrel=1
pkgdesc='Yet another computer algebra system'
url='http://www.yacas.org/'
@@ -18,8 +19,8 @@ if [ ${_build_gui} == "OFF" ]; then
depends=('glibc' 'gcc-libs')
makedepends=('gcc' 'cmake' 'perl')
else
-depends=('glibc' 'gcc-libs' 'qt5-base' 'qt5-webkit' 'qt5-svg')
-makedepends=('gcc' 'cmake' 'perl' 'python-sphinx')
+depends=('dbus' 'libbluray' 'libva' 'libvorbis' 'libxcursor' 'nspr' 'qt5-webengine' 'x264' 'x265' 'xvidcore' 'zstd')
+makedepends=('gcc' 'cmake' 'perl' 'python-sphinx' 'python-sphinxcontrib-bibtex' 'python-sphinx' 'python-sphinx_rtd_theme' 'npm')
fi
#--------------------------------------------------------------
optdepends=('gnuplot' 'lynx' 'texmacs' 'fbreader: Reading EPUB manual')
@@ -27,11 +28,11 @@ conflicts=('yagy')
install=${pkgname}.install
noextract=('yacas.epub')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/grzegorzmazur/yacas/archive/v${pkgver}.tar.gz"
- "https://media.readthedocs.org/epub/yacas/v${pkgver}/yacas.epub"
+ "https://media.readthedocs.org/epub/yacas/v${_docver}/yacas.epub"
"yacas.desktop"
"yacas-docs.desktop"
)
-md5sums=('c955d95b2eee79a59b6df5a2002814de' # yacas source
+md5sums=('cd91867dba8aa858643d4bb9777f608c' # yacas source
'1278f790a15792996931c2adc56dd8aa' # Epub manual
'eb776002fabe21623716ed2642f6d365' # yacas.desktop
'04d2a47c02fba5d88f337a404e02929c' # yacas-docs.desktop
@@ -46,8 +47,10 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_CYACAS_CONSOLE=ON \
-DENABLE_CYACAS_GUI=${_build_gui} \
+ -DENABLE_CYACAS_UNIT_TESTS=OFF \
+ -DENABLE_CYACAS_BENCHMARKS=OFF \
-DENABLE_JYACAS=OFF \
- -DENABLE_DOCS=OFF \
+ -DENABLE_DOCS=ON \
-DENABLE_CYACAS_KERNEL=OFF \
-DCMAKE_BUILD_TYPE=Release
msg "### make" ; make