summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2016-02-25 21:16:32 -0300
committerMarcos Heredia2016-02-25 21:16:32 -0300
commit9e3f25401651dacf8e6f23a51ac5e5df9fcd459d (patch)
tree818fc91e3440a9211d317d9c49807ad68c2982b0
parente0e7d0537f8058f71067cdc0a4c580af10407588 (diff)
downloadaur-9e3f25401651dacf8e6f23a51ac5e5df9fcd459d.tar.gz
Update to 1.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
-rw-r--r--yacas-docs.desktop6
-rw-r--r--yacas.install1
4 files changed, 45 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e72bc13ca14..50e8459a42fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = yacas
pkgdesc = Yet another computer algebra system
- pkgver = 1.3.6
+ pkgver = 1.4.0
pkgrel = 1
- url = http://yacas.sourceforge.net/yacas.html
+ url = http://www.yacas.org/
install = yacas.install
arch = i686
arch = x86_64
@@ -16,12 +16,16 @@ pkgbase = yacas
optdepends = gnuplot
optdepends = lynx
optdepends = texmacs
- source = http://yacas.sourceforge.net/backups/yacas-1.3.6.tar.gz
+ optdepends = fbreader: Reading EPUB manual
+ noextract = yacas.epub
+ source = https://github.com/grzegorzmazur/yacas/archive/v1.4.0.tar.gz
+ source = https://media.readthedocs.org/epub/yacas/latest/yacas.epub
source = yacas.desktop
source = yacas-docs.desktop
- md5sums = 6c5e3b869c1b13d2f4d02d36da964e8d
+ md5sums = 80b86a586d8d56afdd6986686daf0f13
+ md5sums = SKIP
md5sums = 21d4cf6e7658aa0d7c4a0ed14c13f2e9
- md5sums = 50cb74a345f1580a62047d376f6b54e3
+ md5sums = fff8c43f7ab3a77c6f6e181bc3e2687f
pkgname = yacas
diff --git a/PKGBUILD b/PKGBUILD
index d72d4318bf2b..dfaf33b53cc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,45 +4,61 @@
# Maintainer : Marcos Heredia <chelqo@gmail.com>
pkgname=yacas
-pkgver=1.3.6
+pkgver=1.4.0
pkgrel=1
pkgdesc='Yet another computer algebra system'
-url='http://yacas.sourceforge.net/yacas.html'
+url='http://www.yacas.org/'
screenshot='https://dl.dropbox.com/s/dy9evnpl13kdo21/yacas-console.png'
license=('GPL')
groups=("mathematics")
arch=('i686' 'x86_64')
depends=('glibc' 'gcc-libs')
-optdepends=('gnuplot' 'lynx' 'texmacs')
-makedepends=('gcc' 'perl' 'imagemagick')
+optdepends=('gnuplot' 'lynx' 'texmacs' 'fbreader: Reading EPUB manual')
+makedepends=('gcc' 'perl' 'imagemagick' ) #'python3-sphinx')
install=${pkgname}.install
-source=("http://yacas.sourceforge.net/backups/${pkgname}-${pkgver}.tar.gz"
+noextract=('yacas.epub')
+source=("https://github.com/grzegorzmazur/yacas/archive/v${pkgver}.tar.gz"
+ 'https://media.readthedocs.org/epub/yacas/latest/yacas.epub'
'yacas.desktop'
- 'yacas-docs.desktop')
-md5sums=('6c5e3b869c1b13d2f4d02d36da964e8d' # yacas source
+ 'yacas-docs.desktop'
+ )
+md5sums=('80b86a586d8d56afdd6986686daf0f13' # yacas source
+ 'SKIP' # Epub manual
'21d4cf6e7658aa0d7c4a0ed14c13f2e9' # yacas.desktop
- '50cb74a345f1580a62047d376f6b54e3') # yacas-docs.desktop
+ 'fff8c43f7ab3a77c6f6e181bc3e2687f' # yacas-docs.desktop
+ )
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- msg "### makemake" ; ./makemake
- msg "### configure" ; ./configure --prefix=/usr --mandir=/usr/share/man --enable-server
- msg "### make" ; make
- msg "### make check" ; make check
+ [ -d build ] && rm -rf build
+ mkdir build
+ cd build
+ msg "### cmake" ; cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ msg "### make" ; make
+
+# -DENABLE_OLD_DOCS=yes \
+# -DENABLE_DOCS=ON \
+# -DENABLE_JYACAS=yes \
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ cat cmake_install.cmake | grep -v "share/doc" >cmake_install.cmake.tmp
+ mv cmake_install.cmake.tmp cmake_install.cmake
msg "### instalation " ; make DESTDIR=$pkgdir install
+ cd ..
_appdir=${pkgdir}/usr/share/applications
_pngdir=${pkgdir}/usr/share/pixmaps
_docdir=${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
_licdir=${pkgdir}/usr/share/licenses/${pkgname}
- install -dpm755 ${_appdir} ${_pngdir} ${_docdir} ${_licdir}
+ install -dm755 ${_appdir} ${_pngdir} ${_docdir} ${_licdir}
install -Dpm644 ${startdir}/yacas.desktop ${_appdir}/
install -Dpm644 ${startdir}/yacas-docs.desktop ${_appdir}/
convert -crop 500x500+34+110 docs/yacaslogo.png ${_pngdir}/yacas.png
- install -Dpm644 AUTHORS ChangeLog INSTALL NEWS README TODO ${_docdir}/
+ install -Dpm644 AUTHORS ChangeLog INSTALL NEWS README* TODO ${_docdir}/
+ install -Dpm644 ${srcdir}/yacas.epub ${pkgdir}/usr/share/yacas/
install -Dpm644 COPYING ${_licdir}/
- (cd ${_docdir} ; ln -s ../../yacas/documentation .)
+ (cd ${_docdir} ; ln -s ../../yacas/yacas.epub .)
}
diff --git a/yacas-docs.desktop b/yacas-docs.desktop
index df9c451f3fd1..f626a3029377 100644
--- a/yacas-docs.desktop
+++ b/yacas-docs.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
-Name=Yacas documentation
-Name[es]=Documentos de Yacas
+Name=Yacas online documentation
+Name[es]=Documentos de Yacas en la web
Comment=Documentation for Yacas in html format
Comment[es]=Documentos de Yacas en formato html
-Exec=xdg-open /usr/share/yacas/documentation/books.html
+Exec=xdg-open https://yacas.readthedocs.org/
Icon=yacas.png
Terminal=false
Type=Application
diff --git a/yacas.install b/yacas.install
index e111ef946053..91156b2ff811 100644
--- a/yacas.install
+++ b/yacas.install
@@ -1,5 +1,6 @@
post_install() {
update-desktop-database -q
+ echo "A complete EPUB manual is in '/usr/share/yacas/yacas.epub'"
}
post_upgrade() {