summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:06:02 -0300
committerMarcos Heredia2015-06-09 11:06:02 -0300
commite0e7d0537f8058f71067cdc0a4c580af10407588 (patch)
tree2e9c345ba3af3f8b1c749acf3583084a4f1738d9
downloadaur-e0e7d0537f8058f71067cdc0a4c580af10407588.tar.gz
Initial import
-rw-r--r--.AURINFO24
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD48
-rw-r--r--yacas-docs.desktop10
-rw-r--r--yacas.desktop9
-rw-r--r--yacas.install11
6 files changed, 129 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..65f0037e15a0
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,24 @@
+pkgbase = yacas
+ pkgdesc = Yet another computer algebra system
+ pkgver = 1.3.6
+ pkgrel = 1
+ url = http://yacas.sourceforge.net/yacas.html
+ install = yacas.install
+ arch = i686
+ arch = x86_64
+ groups = mathematics
+ license = GPL
+ makedepends = gcc
+ makedepends = perl
+ makedepends = imagemagick
+ depends = glibc
+ depends = gcc-libs
+ optdepends = gnuplot
+ optdepends = lynx
+ optdepends = texmacs
+ source = http://yacas.sourceforge.net/backups/yacas-1.3.6.tar.gz
+ source = yacas.desktop
+ source = yacas-docs.desktop
+
+pkgname = yacas
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e72bc13ca14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = yacas
+ pkgdesc = Yet another computer algebra system
+ pkgver = 1.3.6
+ pkgrel = 1
+ url = http://yacas.sourceforge.net/yacas.html
+ install = yacas.install
+ arch = i686
+ arch = x86_64
+ groups = mathematics
+ license = GPL
+ makedepends = gcc
+ makedepends = perl
+ makedepends = imagemagick
+ depends = glibc
+ depends = gcc-libs
+ optdepends = gnuplot
+ optdepends = lynx
+ optdepends = texmacs
+ source = http://yacas.sourceforge.net/backups/yacas-1.3.6.tar.gz
+ source = yacas.desktop
+ source = yacas-docs.desktop
+ md5sums = 6c5e3b869c1b13d2f4d02d36da964e8d
+ md5sums = 21d4cf6e7658aa0d7c4a0ed14c13f2e9
+ md5sums = 50cb74a345f1580a62047d376f6b54e3
+
+pkgname = yacas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d72d4318bf2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Stefan Husmann <stefan.husmann@t-systems.com>
+# Contributor: Stéphane Gaudreault <Stephane.Gaudreault@gmail.com>
+# Maintainer : Marcos Heredia <chelqo@gmail.com>
+
+pkgname=yacas
+pkgver=1.3.6
+pkgrel=1
+pkgdesc='Yet another computer algebra system'
+url='http://yacas.sourceforge.net/yacas.html'
+screenshot='https://dl.dropbox.com/s/dy9evnpl13kdo21/yacas-console.png'
+license=('GPL')
+groups=("mathematics")
+arch=('i686' 'x86_64')
+depends=('glibc' 'gcc-libs')
+optdepends=('gnuplot' 'lynx' 'texmacs')
+makedepends=('gcc' 'perl' 'imagemagick')
+install=${pkgname}.install
+source=("http://yacas.sourceforge.net/backups/${pkgname}-${pkgver}.tar.gz"
+ 'yacas.desktop'
+ 'yacas-docs.desktop')
+md5sums=('6c5e3b869c1b13d2f4d02d36da964e8d' # yacas source
+ '21d4cf6e7658aa0d7c4a0ed14c13f2e9' # yacas.desktop
+ '50cb74a345f1580a62047d376f6b54e3') # yacas-docs.desktop
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ msg "### makemake" ; ./makemake
+ msg "### configure" ; ./configure --prefix=/usr --mandir=/usr/share/man --enable-server
+ msg "### make" ; make
+ msg "### make check" ; make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ msg "### instalation " ; make DESTDIR=$pkgdir install
+ _appdir=${pkgdir}/usr/share/applications
+ _pngdir=${pkgdir}/usr/share/pixmaps
+ _docdir=${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
+ _licdir=${pkgdir}/usr/share/licenses/${pkgname}
+ install -dpm755 ${_appdir} ${_pngdir} ${_docdir} ${_licdir}
+ install -Dpm644 ${startdir}/yacas.desktop ${_appdir}/
+ install -Dpm644 ${startdir}/yacas-docs.desktop ${_appdir}/
+ convert -crop 500x500+34+110 docs/yacaslogo.png ${_pngdir}/yacas.png
+ install -Dpm644 AUTHORS ChangeLog INSTALL NEWS README TODO ${_docdir}/
+ install -Dpm644 COPYING ${_licdir}/
+ (cd ${_docdir} ; ln -s ../../yacas/documentation .)
+}
diff --git a/yacas-docs.desktop b/yacas-docs.desktop
new file mode 100644
index 000000000000..df9c451f3fd1
--- /dev/null
+++ b/yacas-docs.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Yacas documentation
+Name[es]=Documentos de Yacas
+Comment=Documentation for Yacas in html format
+Comment[es]=Documentos de Yacas en formato html
+Exec=xdg-open /usr/share/yacas/documentation/books.html
+Icon=yacas.png
+Terminal=false
+Type=Application
+Categories=Science;Math;
diff --git a/yacas.desktop b/yacas.desktop
new file mode 100644
index 000000000000..903fc7dacb47
--- /dev/null
+++ b/yacas.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Yacas
+Comment=Yacas is a small and highly flexible computer algebra language
+Comment[es]=Yacas es un lenguaje de computacion algebraico
+Exec=yacas
+Icon=yacas.png
+Terminal=true
+Type=Application
+Categories=ConsoleOnly;Science;Math;
diff --git a/yacas.install b/yacas.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/yacas.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}