summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2020-05-21 18:41:46 +0800
committerSukanka2020-05-21 18:41:46 +0800
commit618f3208d67436daa18e3cfbf268923537755163 (patch)
treeeccd4bdef0ed512299dfb416fe67523fd1554b88
downloadaur-618f3208d67436daa18e3cfbf268923537755163.tar.gz
Initial commit
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD67
2 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0322454a285a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = yade
+ pkgdesc = An Open Source Discrete Element Method
+ pkgver = 2020.01a
+ pkgrel = 1
+ url = https://yade-dem.org/doc/index.html
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = boost
+ depends = qt5-base
+ depends = freeglut
+ depends = libqglviewer
+ depends = eigen
+ depends = gdb
+ depends = sqlite
+ depends = python
+ depends = python-numpy
+ depends = ipython
+ depends = python-sphinx
+ depends = python-mpi4py
+ depends = python-matplotlib
+ depends = python-xlib
+ depends = python-future
+ depends = python-minieigen-git
+ depends = python-pygraphviz
+ depends = loki-lib
+ optdepends = gl2ps: an OpenGL to PostScript printing library
+ optdepends = vtk: open source software for manipulating and displaying scientific data (Recommended)
+ optdepends = cgal: Computational Geometry Algorithms Library
+ optdepends = suitesparse: sparse algebra library (fluid coupling)
+ optdepends = openblas: optimized and parallelized alternative to the standard blas+lapack (fluid coupling)
+ optdepends = metis: matrix preconditioning (fluid coupling)
+ optdepends = openmpi: library for parallel distributed computing (For MPI and OpenFOAM coupling)
+ optdepends = coin-or-asl: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = coin-or-cbc: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = coin-or-cgl: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = coin-or-clp: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = coin-or-coinutils: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = coin-or-mp: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = coin-or-osi: Linear Programming Solver in group coin-or (For PotentialBlock)
+ optdepends = mpfr: multiple-precision floating-point library (with python-mpmath)
+ optdepends = python-mpmath: arbitrary-precision floating-point library (with mpfr)
+ optdepends = cuda: to activate GPU accelerated PFV
+ provides = yade
+ source = https://launchpad.net/yade/trunk/yade-1.00.0/+download/yade-2020.01a.tar.bz2
+ sha512sums = 91262e24e361bd2f7139426fe32273efb8907271d870eb4f71cf659a2b4ef391123c3e60c39dea1255bbdc4c1ff442a40e0a9eaeb0fff84ade28bd945da6c16e
+
+pkgname = yade
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a33897ca515d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Sukanka <su975853527 [AT] gmail.com>
+pkgname=yade
+pkgver=2020.01a
+pkgrel=1
+pkgdesc="An Open Source Discrete Element Method"
+arch=("x86_64")
+url='https://yade-dem.org/doc/index.html'
+license=('GPL2')
+depends=(
+ 'boost' 'qt5-base' 'freeglut' 'libqglviewer' 'eigen' 'gdb' 'sqlite'
+ 'python' 'python-numpy' 'ipython' 'python-sphinx' 'python-mpi4py'
+ 'python-matplotlib' 'python-xlib' 'python-future'
+ # AUR packages
+ 'python-minieigen-git' 'python-pygraphviz' 'loki-lib'
+)
+#boost libqglviewer ipython python-sphinx python-mpi4py python-matplotlib eigen loki vtk cgal coin-or python-mpmath python-pygraphviz python-xlib python-minieigen-git python-future
+optdepends=(
+ 'gl2ps: an OpenGL to PostScript printing library'
+ 'vtk: open source software for manipulating and displaying scientific data (Recommended)'
+ 'cgal: Computational Geometry Algorithms Library'
+ 'suitesparse: sparse algebra library (fluid coupling)'
+ 'openblas: optimized and parallelized alternative to the standard blas+lapack (fluid coupling)'
+ 'metis: matrix preconditioning (fluid coupling)'
+ 'openmpi: library for parallel distributed computing (For MPI and OpenFOAM coupling)'
+ # simply use sudo pacman -S coin-or to install the following:
+ 'coin-or-asl: Linear Programming Solver in group coin-or (For PotentialBlock)'
+ 'coin-or-cbc: Linear Programming Solver in group coin-or (For PotentialBlock)'
+ 'coin-or-cgl: Linear Programming Solver in group coin-or (For PotentialBlock)'
+ 'coin-or-clp: Linear Programming Solver in group coin-or (For PotentialBlock)'
+ 'coin-or-coinutils: Linear Programming Solver in group coin-or (For PotentialBlock)'
+ 'coin-or-mp: Linear Programming Solver in group coin-or (For PotentialBlock)'
+ 'coin-or-osi: Linear Programming Solver in group coin-or (For PotentialBlock)'
+
+ 'mpfr: multiple-precision floating-point library (with python-mpmath)'
+ 'python-mpmath: arbitrary-precision floating-point library (with mpfr)'
+ 'cuda: to activate GPU accelerated PFV'
+)
+makedepends=('cmake')
+provides=('yade')
+source=("https://launchpad.net/yade/trunk/yade-1.00.0/+download/yade-${pkgver}.tar.bz2")
+sha512sums=('91262e24e361bd2f7139426fe32273efb8907271d870eb4f71cf659a2b4ef391123c3e60c39dea1255bbdc4c1ff442a40e0a9eaeb0fff84ade28bd945da6c16e')
+
+
+
+prepare(){
+ cd "$srcdir"
+ # Follow https://yade-dem.org/doc/installation.html#compilation
+ mv trunk-${pkgver} trunk
+ mkdir build
+}
+build(){
+ cd "$srcdir"/build
+ # I hope CMAKE_INSTALL_PREFIX=/usr won't cause bugs.
+ # WARNING: Package contains reference to $srcdir, but all to "$srcdir"/trunk, I think it's safe.
+ # Anyway, I still want to deal with this, but need help.
+ cmake ../trunk \
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_SPH=ON -DENABLE_PROFILING=ON -DCHOLMOD_GPU=ON -DENABLE_PYTHON3=ON -DENABLE_LIQMIGRATION=ON -DENABLE_MASK_ARBITRARY=ON -DNOSUFFIX=ON \
+ -DENABLE_USEFUL_ERRORS=OFF # or build will fail!
+ make -j10
+}
+
+package(){
+ cd "$srcdir"/build
+# mv lib64 lib
+ make install DESTDIR="${pkgdir}"
+}