summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2023-02-04 15:09:51 +0800
committersukanka2023-02-04 15:09:51 +0800
commit15230eba6bbc770e9e40e8cd02a81ad8d55eca4e (patch)
tree53064a1b3aefab8b2730ff79690fd126f268b9be
parentfd622a409b9f768d39019c7c71b525a75372c565 (diff)
downloadaur-15230eba6bbc770e9e40e8cd02a81ad8d55eca4e.tar.gz
update to 2023.02a
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 33 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 575547fff087..6e6ff800ea56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,26 @@
pkgbase = yade-doc
pkgdesc = Yet Another Dynamic Engine, free software for discrete element modeling Documentation
- pkgver = 2022.01a
- pkgrel = 4
+ pkgver = 2023.02a
+ pkgrel = 1
url = https://yade-dem.org/doc/index.html
- arch = x86_64
+ arch = any
license = GPL2
makedepends = yade
makedepends = python-sphinx
makedepends = python-bibtexparser
+ makedepends = python-ipython-genutils
makedepends = texlive-bin
+ makedepends = texlive-core
+ makedepends = texlive-latexextra
+ makedepends = texlive-pictures
makedepends = help2man
- source = trunk-2022.01a::git+https://gitlab.com/yade-dev/trunk.git?commit=fd04d864622a1c628296ccd1697efc93cda98c27
+ makedepends = openssh
+ makedepends = fmt
+ makedepends = cmake
+ makedepends = tk
+ source = trunk-2023.02a.tar.gz::https://gitlab.com/yade-dev/trunk/-/archive/2023.02a/trunk-2023.02a.tar.gz
source = yade-doc.patch
- sha512sums = SKIP
+ sha512sums = d93247bf86f9aa711b27b4258b711d5be448c8bffb78df8bc3a0691bb0d986ffe876a47a70eed43b1729b496ffd892f4d1137a397bc038539e95b695173da53c
sha512sums = ffd3b27b8ccb9c6a8adaa7858d01b74b2fcbda64e6d1673b11cc33dc52a278b0ba4fd558352d15366f52023a6053c055546b5c8febccce1d1439cf6b5a3a755d
pkgname = yade-doc
diff --git a/PKGBUILD b/PKGBUILD
index 4ea89922fc1d..ae1fe12d0b39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,49 @@
# Maintainer: Sukanka <su975853527 [AT] gmail.com>
pkgname=yade-doc
-pkgver=2022.01a
-pkgrel=4
+pkgver=2023.02a
+pkgrel=1
pkgdesc="Yet Another Dynamic Engine, free software for discrete element modeling Documentation"
-arch=("x86_64")
+arch=("any")
url='https://yade-dem.org/doc/index.html'
license=('GPL2')
-makedepends=(
+makedepends=(
'yade'
- # for make doc
+ # for make doc
'python-sphinx'
'python-bibtexparser'
+ 'python-ipython-genutils'
'texlive-bin'
+ 'texlive-core'
+ 'texlive-latexextra'
+ 'texlive-pictures'
# for manpage
'help2man'
+ 'openssh'
+ 'fmt' 'cmake' 'tk'
)
-source=("trunk-${pkgver}::git+https://gitlab.com/yade-dev/trunk.git?commit=fd04d864622a1c628296ccd1697efc93cda98c27"
+source=("trunk-${pkgver}.tar.gz::https://gitlab.com/yade-dev/trunk/-/archive/${pkgver}/trunk-${pkgver}.tar.gz"
"${pkgname}.patch"
)
-sha512sums=('SKIP'
+sha512sums=('d93247bf86f9aa711b27b4258b711d5be448c8bffb78df8bc3a0691bb0d986ffe876a47a70eed43b1729b496ffd892f4d1137a397bc038539e95b695173da53c'
'ffd3b27b8ccb9c6a8adaa7858d01b74b2fcbda64e6d1673b11cc33dc52a278b0ba4fd558352d15366f52023a6053c055546b5c8febccce1d1439cf6b5a3a755d')
-
+
prepare(){
# Follow https://yade-dem.org/doc/installation.html#compilation
test -d trunk && rm -rf trunk
- mv trunk-${pkgver} trunk
+ mv trunk-${pkgver} trunk
test -d build || mkdir build
- cd trunk
- patch --strip=1 < ../${pkgname}.patch
+ cd trunk
+ patch --strip=1 < ../${pkgname}.patch
}
package(){
cd "$srcdir"/build
- mkdir -p ${pkgdir}/usr/share/doc/${pkgbase}
- mkdir -p ${pkgdir}/usr/share/man/
+ install -d ${pkgdir}/usr/share/doc/${pkgbase}
+ install -d ${pkgdir}/usr/share/man/man1
cmake ../trunk \
-DCMAKE_INSTALL_PREFIX=/usr -DNOSUFFIX=ON \
-DYADE_DOC_PATH=${pkgdir}/usr/share/doc/${pkgbase} \
- -DYADE_MAN_PATH=${pkgdir}/usr/share/man1/
+ -DYADE_MAN_PATH=${pkgdir}/usr/share/man/man1/
make doc
make manpage
}