summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2015-06-01 06:34:09 -0700
committerMike Swanson2015-06-01 06:34:09 -0700
commit02596980c9efe24a513a45367ce6a7dd0d0c2dfb (patch)
tree06bce4e40bfaa06e722b6b2362381dc72bbc0b30
parent35da48ea396e11f9791c1e90536665b67702e3c9 (diff)
downloadaur-02596980c9efe24a513a45367ce6a7dd0d0c2dfb.tar.gz
use tar.gz download instead, fixes checksum
the generated Zip doesn't match the checksum the PKGBUILD had; even a locally-created zip with git archive produced the same checksum as GitHub made. Did the Zip generation change somehow? I don't know, but I'll fix it by just using tar.gz.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e95fdfba75f..e82bf5f122af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yadex
pkgdesc = A Doom level editor with additional support for Heretic, Hexen and Strife
pkgver = 1.7.0
- pkgrel = 5
+ pkgrel = 6
url = http://www.teaser.fr/~amajorel/yadex/
install = yadex.install
arch = i686
@@ -12,8 +12,8 @@ pkgbase = yadex
optdepends = freedoom
optdepends = doom1-wad
backup = etc/yadex.cfg
- source = https://github.com/chungy/yadex/archive/bf9d7d76ea0ca6e61a26cf624996527799f254a3.zip
- sha256sums = 0ece732a8dc392ff7becc01005c722a9ad4ca0868b5656a3dd90469a15518d18
+ source = https://github.com/chungy/yadex/archive/bf9d7d76ea0ca6e61a26cf624996527799f254a3.tar.gz
+ sha256sums = e71e53d9d4cf2fa1485bffce848c7a0d3f3522ba417c7e6646b9cc01c4a02e23
pkgname = yadex
diff --git a/.gitignore b/.gitignore
index 376a69d6c613..665307854be8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
*.pkg.tar*
*.src.tar*
-*.zip
+*.gz
src
pkg
diff --git a/PKGBUILD b/PKGBUILD
index b54f121c7dc0..2a3f058ac2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=yadex
pkgver=1.7.0
-pkgrel=5
+pkgrel=6
pkgdesc="A Doom level editor with additional support for Heretic, Hexen and Strife"
gitid=bf9d7d76ea0ca6e61a26cf624996527799f254a3
arch=('i686' 'x86_64')
@@ -12,8 +12,8 @@ depends=('libx11' 'gcc-libs')
optdepends=('freedoom' 'doom1-wad')
backup=('etc/yadex.cfg')
install=$pkgname.install
-source=(https://github.com/chungy/yadex/archive/${gitid}.zip)
-sha256sums=('0ece732a8dc392ff7becc01005c722a9ad4ca0868b5656a3dd90469a15518d18')
+source=(https://github.com/chungy/yadex/archive/${gitid}.tar.gz)
+sha256sums=('e71e53d9d4cf2fa1485bffce848c7a0d3f3522ba417c7e6646b9cc01c4a02e23')
build() {
cd $pkgname-$gitid