summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2014-01-08 04:05:35 -0800
committerMike Swanson2014-01-08 04:05:35 -0800
commit35da48ea396e11f9791c1e90536665b67702e3c9 (patch)
treebfe428a6a12404e312d9e34ee69398329d735830
downloadaur-35da48ea396e11f9791c1e90536665b67702e3c9.tar.gz
Add Yadex
I set up a Git repository with all the historical versions and the patches in a single place. Hopefully less trouble than always going out manually for it all. :)
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
-rw-r--r--yadex.install10
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e95fdfba75f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = yadex
+ pkgdesc = A Doom level editor with additional support for Heretic, Hexen and Strife
+ pkgver = 1.7.0
+ pkgrel = 5
+ url = http://www.teaser.fr/~amajorel/yadex/
+ install = yadex.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libx11
+ depends = gcc-libs
+ optdepends = freedoom
+ optdepends = doom1-wad
+ backup = etc/yadex.cfg
+ source = https://github.com/chungy/yadex/archive/bf9d7d76ea0ca6e61a26cf624996527799f254a3.zip
+ sha256sums = 0ece732a8dc392ff7becc01005c722a9ad4ca0868b5656a3dd90469a15518d18
+
+pkgname = yadex
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..376a69d6c613
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.zip
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b54f121c7dc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+pkgname=yadex
+pkgver=1.7.0
+pkgrel=5
+pkgdesc="A Doom level editor with additional support for Heretic, Hexen and Strife"
+gitid=bf9d7d76ea0ca6e61a26cf624996527799f254a3
+arch=('i686' 'x86_64')
+url="http://www.teaser.fr/~amajorel/yadex/"
+license=('GPL2')
+depends=('libx11' 'gcc-libs')
+optdepends=('freedoom' 'doom1-wad')
+backup=('etc/yadex.cfg')
+install=$pkgname.install
+source=(https://github.com/chungy/yadex/archive/${gitid}.zip)
+sha256sums=('0ece732a8dc392ff7becc01005c722a9ad4ca0868b5656a3dd90469a15518d18')
+
+build() {
+ cd $pkgname-$gitid
+
+ ./configure --prefix=/usr
+
+ make CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+package() {
+ cd $pkgname-$gitid
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/yadex.install b/yadex.install
new file mode 100644
index 000000000000..1b20aa01dd7f
--- /dev/null
+++ b/yadex.install
@@ -0,0 +1,10 @@
+post_install() {
+ cat <<- EOF
+ :: Before using yadex, check the paths
+ :: to your IWAD files in /etc/yadex.cfg
+ EOF
+}
+
+post_upgrade() {
+ post_install $1
+}