summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlackEagle Gitlab Runner2021-04-25 09:56:59 +0000
committerBlackEagle Gitlab Runner2021-04-25 09:56:59 +0000
commit74ba013b0937dac33e5ca6e99bcff3339d05f3db (patch)
treedcadb64040102c72a2925a3bf09906ed67d275a3
parent47e422b86250da2546ae9538fe5739c13a3f2394 (diff)
downloadaur-74ba013b0937dac33e5ca6e99bcff3339d05f3db.tar.gz
yadifa :: 2.4.2-2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--yadifa.service27
3 files changed, 62 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e974b522054e..47ea382a1bdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
# Generated by makepkg 5.2.2
-# Tue Oct 13 15:02:17 UTC 2020
+# Sun Apr 25 09:56:59 UTC 2021
pkgbase = yadifa
pkgdesc = lightweight authoritative Name Server with DNSSEC capabilities
- pkgver = 2.4.0
- pkgrel = 1
+ pkgver = 2.4.2
+ pkgrel = 2
url = http://www.yadifa.eu
arch = x86_64
- license = FreeBSD
+ license = BSD
depends = openssl
options = !libtool
backup = etc/yadifad.conf
- source = http://cdn.yadifa.eu/sites/default/files/releases/yadifa-2.4.0-9809.tar.gz
+ source = https://www.yadifa.eu/sites/default/files/releases/yadifa-2.4.2-9997.tar.gz
+ source = https://www.yadifa.eu/sites/default/files/yadifa-2.4.2-9997.tar.gz.asc
source = yadifa.service
- sha256sums = 7e0ef3bed2cdca3d39681aba8bb58c3d85e748b3c5580f9306f8ff7f890f8a84
- sha256sums = 438fff4a6c81cb5d2bd35d276abdae6cf5de04c997b7b7d893fdbf3372034130
+ validpgpkeys = 9DF4F4485F6FC40513572886A75042DBD6669651
+ sha256sums = 000fba3805d5a85df92925f3b36714b65edf874309da9295be380d7a98f02b38
+ sha256sums = SKIP
+ sha256sums = f8a232461a4db320b40eed3573cfc71922c31b33dc5f5dd438a2b18f59e3daf7
pkgname = yadifa
diff --git a/PKGBUILD b/PKGBUILD
index d98a2a8de9b2..04e4ba93c04d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,41 @@
# Maintainer: BlackIkeEagle <ike DOT devolder AT gmail DOT com>
pkgname=yadifa
-pkgver=2.4.0
-_buildnr=9809
-pkgrel=1
+pkgver=2.4.2
+_buildnr=9997
+pkgrel=2
pkgdesc="lightweight authoritative Name Server with DNSSEC capabilities"
arch=('x86_64')
url="http://www.yadifa.eu"
-license=('FreeBSD')
+license=('BSD')
depends=('openssl')
backup=('etc/yadifad.conf')
options=(!libtool)
source=(
- "http://cdn.yadifa.eu/sites/default/files/releases/$pkgname-$pkgver-$_buildnr.tar.gz"
+ "https://www.yadifa.eu/sites/default/files/releases/$pkgname-$pkgver-$_buildnr.tar.gz"
+ "https://www.yadifa.eu/sites/default/files/$pkgname-$pkgver-$_buildnr.tar.gz.asc"
'yadifa.service'
)
-sha256sums=('7e0ef3bed2cdca3d39681aba8bb58c3d85e748b3c5580f9306f8ff7f890f8a84'
- '438fff4a6c81cb5d2bd35d276abdae6cf5de04c997b7b7d893fdbf3372034130')
+sha256sums=('000fba3805d5a85df92925f3b36714b65edf874309da9295be380d7a98f02b38'
+ 'SKIP'
+ 'f8a232461a4db320b40eed3573cfc71922c31b33dc5f5dd438a2b18f59e3daf7')
+
+validpgpkeys=(
+ '9DF4F4485F6FC40513572886A75042DBD6669651' # "yadifa"
+)
build() {
cd $pkgname-$pkgver-$_buildnr
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --enable-dynamic-provisioning \
- --enable-rrl
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-tools \
+ --enable-rrl \
+ --enable-nsid \
+ --enable-ctrl \
+ --enable-systemd-resolved-avoidance
make
}
@@ -35,7 +44,8 @@ package(){
make DESTDIR="$pkgdir" install
# systemd service file
- install -Dm644 "$srcdir/yadifa.service" "$pkgdir/usr/lib/systemd/system/yadifa.service"
+ install -Dm644 "$srcdir/yadifa.service" \
+ "$pkgdir/usr/lib/systemd/system/yadifa.service"
# little cleanup
rm -rf "$pkgdir/var/run"
diff --git a/yadifa.service b/yadifa.service
index aef319535d09..e963d6dc8ad6 100644
--- a/yadifa.service
+++ b/yadifa.service
@@ -8,3 +8,30 @@ KillMode=process
[Install]
WantedBy=multi-user.target
+
+[Unit]
+Description=YADIFA Domain Name Server
+Documentation=man:yadifad(8)
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/sbin/yadifad --nodaemon
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+CapabilityBoundingSet=CAP_CHOWN CAP_DAC_OVERRIDE CAP_IPC_LOCK CAP_NET_BIND_SERVICE CAP_SETGID CAP_SETUID CAP_SYS_CHROOT
+MemoryDenyWriteExecute=true
+NoNewPrivileges=true
+PrivateDevices=true
+PrivateTmp=true
+ProtectHome=true
+ProtectControlGroups=true
+ProtectKernelModules=true
+ProtectKernelTunables=true
+ProtectSystem=strict
+ReadOnlyPaths=/etc/yadifa
+ReadWritePaths=/run /var/lib/yadifa /var/log/yadifa
+RestrictRealtime=true
+
+[Install]
+WantedBy=multi-user.target