summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorE5ten2018-04-22 12:46:46 -0400
committerE5ten2018-04-22 12:46:46 -0400
commit69bf6f59a0df7792e8a2f8aa9bd66851c71769e7 (patch)
tree91e386ba02fe051abd10eb1312654e23fe95824c
parentf936f779226dc4058db6d33501c00d5bd6fc7ce6 (diff)
downloadaur-69bf6f59a0df7792e8a2f8aa9bd66851c71769e7.tar.gz
update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aee73b958cb..b9098b10ae2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = yadshot
pkgdesc = yadshot provides a GUI frontend for taking screenshots using imagemagick/slop and uploads files and pastes to teknik.io
- pkgver = 0.1.99.2
+ pkgver = 0.2.00
pkgrel = 1
url = http://www.simonizor.net
arch = x86_64
license = GPL
depends = slop
- depends = imagemagick
depends = yad
depends = xclip
depends = curl
- source = https://github.com/simoniz0r/yadshot/archive/0.1.99.2.tar.gz
+ optdepends = ffmpeg: screenshot backend
+ optdepends = imagemagick: screenshot backend
+ source = https://github.com/simoniz0r/yadshot/archive/0.2.00.tar.gz
md5sums = SKIP
pkgname = yadshot
diff --git a/PKGBUILD b/PKGBUILD
index 7c6c2e538a57..8cfdfb6ec7aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: E5ten
pkgname=yadshot
-pkgver=0.1.99.2
+pkgver=0.2.00
pkgrel=1
pkgdesc="yadshot provides a GUI frontend for taking screenshots using imagemagick/slop and uploads files and pastes to teknik.io "
arch=('x86_64')
url='http://www.simonizor.net'
license=('GPL')
-depends=('slop' 'imagemagick' 'yad' 'xclip' 'curl')
+depends=('slop' 'yad' 'xclip' 'curl')
+optdepends=('ffmpeg: screenshot backend'
+ 'imagemagick: screenshot backend')
source=("https://github.com/simoniz0r/$pkgname/archive/$pkgver.tar.gz")
md5sums=('SKIP')
@@ -19,4 +21,5 @@ prepare() {
package() {
cd $srcdir/$pkgname-$pkgver
make DESTDIR="$pkgdir/" install
+ echo "This package requires ffmpeg or imagemagick as a screenshot backend, please install something providing one or the other."
}