summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2017-03-29 22:38:00 +0200
committerLukáš Jirkovský2017-03-29 22:38:00 +0200
commit62858a36582a4a804388136a7a0738d06a683b58 (patch)
tree100247642f3f00e2e851dcc44ba45c7b48848950
parentff7b0f4b5b0cdb17308e7186821cb3130341b306 (diff)
downloadaur-yafaray-git.tar.gz
update for python 3.6, fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--pluginpath.diff20
3 files changed, 7 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d7526ee0f84..091987294c8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Aug 8 18:30:48 UTC 2016
+# Wed Mar 29 20:38:00 UTC 2017
pkgbase = yafaray-git
pkgdesc = A free open-source raytracing engine
- pkgver = 971.573e158
+ pkgver = 1061.ec7a1f1
pkgrel = 1
url = http://www.yafaray.org/
arch = i686
@@ -22,9 +22,7 @@ pkgbase = yafaray-git
provides = yafaray
conflicts = yafaray
source = yafaray::git+git://github.com/YafaRay/Core.git
- source = pluginpath.diff
md5sums = SKIP
- md5sums = bab516f2be6bc15491acd53df7a50a69
pkgname = yafaray-git
diff --git a/PKGBUILD b/PKGBUILD
index a7c6293f7798..812c1df9351b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=yafaray-git
-pkgver=971.573e158
+pkgver=1061.ec7a1f1
pkgrel=1
pkgdesc="A free open-source raytracing engine"
arch=('i686' 'x86_64')
@@ -12,15 +12,8 @@ optdepends=('qt4: QT GUI' 'python: Python bindings'
makedepends=('cmake' 'git' 'qt4' 'swig' 'python')
provides=('yafaray')
conflicts=('yafaray')
-source=('yafaray::git+git://github.com/YafaRay/Core.git'
- 'pluginpath.diff')
-md5sums=('SKIP'
- 'bab516f2be6bc15491acd53df7a50a69')
-
-prepare() {
- cd "$srcdir/yafaray"
- patch -Np1 < "$srcdir/pluginpath.diff"
-}
+source=('yafaray::git+git://github.com/YafaRay/Core.git')
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/yafaray"
@@ -32,8 +25,8 @@ build() {
cmake . \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DYAF_PY_VERSION=3.5 \
- -DYAF_BINDINGS_PY_DIR=/usr/lib/python3.5
+ -DYAF_PY_VERSION=3.6 \
+ -DYAF_BINDINGS_PY_DIR=/usr/lib/python3.6
make
}
diff --git a/pluginpath.diff b/pluginpath.diff
deleted file mode 100644
index b8f913f4e33e..000000000000
--- a/pluginpath.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/src/yafraycore/environment.cc b/src/yafraycore/environment.cc
-index fdf1c7c..69cb247 100755
---- a/src/yafraycore/environment.cc
-+++ b/src/yafraycore/environment.cc
-@@ -137,13 +137,8 @@ void renderEnvironment_t::loadPlugins(const std::string &path)
-
- bool renderEnvironment_t::getPluginPath(std::string &path)
- {
-- //Get plugin path from a subfolder of the current yafaray_xml executable file path
-- if(!session.getPathYafaRayXml().empty())
-- {
-- path = session.getPathYafaRayXml()+"/plugins/";
-- return true;
-- }
-- else return false;
-+ path = "/usr/lib/yafaray/";
-+ return true;
- }
-
-