summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 11:46:00 +0800
committerDaniel YC Lin2015-06-13 11:46:00 +0800
commitffc4d8f36d79ce41a525a90092bf9a79c24416f1 (patch)
treeac3ee49749635b1ae33208199e5919babc8997f0
downloadaur-ffc4d8f36d79ce41a525a90092bf9a79c24416f1.tar.gz
merge to aur4
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD45
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..346a1aecb583
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yaffs2utils-svn
+ pkgdesc = A collection of utilities to make/extract a YAFFS2/YAFFS1 image for Linux.
+ pkgver = 51
+ pkgrel = 1
+ url = http://code.google.com/p/yaffs2utils
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = svn
+ makedepends = gcc
+ depends = glibc
+ conflicts = yaffs2utils-latest
+ conflicts = yaffs2utils
+ options = strip
+
+pkgname = yaffs2utils-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05e7a6298f95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## Ignore everything
+*.zip
+*.xz
+*.gz
+*.bz2
+*.7z
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c97f47b560c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Daniel YC Lin <dlin.tw gmail>
+# Contributor: allencch <allencch hotmail>
+
+pkgname=yaffs2utils-svn
+pkgver=51
+pkgrel=1
+pkgdesc="A collection of utilities to make/extract a YAFFS2/YAFFS1 image for Linux."
+arch=(i686 x86_64)
+url=http://code.google.com/p/yaffs2utils
+license=('GPL2')
+makedepends=('svn' 'gcc')
+depends=('glibc')
+options=('strip')
+conflicts=('yaffs2utils-latest' 'yaffs2utils')
+source=()
+
+_svntrunk="http://yaffs2utils.googlecode.com/svn/trunk/"
+_svnmod="yaffs2utils-svn"
+
+build() {
+ cd $srcdir
+ msg "Connecting to $_svntrunk SVN server...."
+ if [ -d "$_svnmod/.svn" ]; then
+ (cd "$_svnmod" && svn up -r "$pkgver" )
+ else
+ svn co "$_svntrunk" --config-dir ./ -r "$pkgver" "$_svnmod"
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting build..."
+
+ svn export --force $_svnmod $_svnmod-build
+ cd $_svnmod-build
+ touch configs.h
+ sed -i 's/\($(CC) \)$(LDFLAGS)\(.*\)$/\1\2 $(LDFLAGS)/g' Makefile
+ make
+}
+
+package() {
+ cd $_svnmod-build
+ mkdir -p $pkgdir/usr/bin/
+ install -m 0755 $srcdir/$_svnmod-build/mkyaffs2 \
+ $srcdir/$_svnmod-build/unyaffs2 $pkgdir/usr/bin/
+}
+# vim:set ts=2 sw=2 et sta: