summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32025-03-24 20:27:17 +0100
committergilcu32025-03-24 20:27:17 +0100
commit739fd25c7f8a91c77f180fafb33d4e8e1fbcc203 (patch)
tree9244a4c4c72c70779d75eeece3b4ca8f8aa181ba
parentf169bce20e39d452bc6b950c74965c8c05b123e3 (diff)
downloadaur-739fd25c7f8a91c77f180fafb33d4e8e1fbcc203.tar.gz
upgpkg: yafu-git r714.83690bc-1
fix build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2018ea8f3dc8..8e04f11bbb9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yafu-git
pkgdesc = Automated integer factorization.
- pkgver = r640.ee519b2
+ pkgver = r714.83690bc
pkgrel = 1
url = https://github.com/bbuhrow/yafu
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 63027206c56c..11b94001dc1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: KUMAX <kumax2048@pm.me>
+# Maintainer: gilcu3
+# Previous Maintainer: KUMAX <kumax2048@pm.me>
+# Contributor: KUMAX
_pkgbase=yafu
pkgname=yafu-git
pkgrel=1
-pkgver=r640.ee519b2
+pkgver=r714.83690bc
pkgdesc="Automated integer factorization."
url=https://github.com/bbuhrow/yafu
license=("MIT")
arch=('x86_64')
conflicts=(${_pkgbase})
provides=('yafu' 'ysieve')
-#makedepends=('zlib' 'msieve') ## These dependencies are related to some features, but they are not tested for being sufficient to make yafu work.
makedepends=('git' 'subversion')
depends=('gmp' 'gmp-ecm')
optdepends=('ggnfs')
@@ -54,7 +55,13 @@ build() {
make all NO_ZLIB=1
cd ${srcdir}/yafu
- make yafu CC=gcc NFS=1 CFLAGS="$CFLAGS -g -m64 -std=gnu99 -DUSE_SSE2 -fno-common -DUSE_NFS -O2 -fomit-frame-pointer -Wall -I. -Iinclude -Itop/aprcl -Itop/cmdParser -Itop/ -Ifactor/gmp-ecm -I../ysieve -I../ytools -I../msieve/zlib -Wno-error=implicit-function-declaration -Wno-error=incompatible-pointer-types -Wno-error=return-mismatch"
+ make yafu CC=gcc NFS=1 CFLAGS="$CFLAGS -g -m64 -std=gnu99 -DUSE_SSE2 -fno-common -DUSE_NFS -O2 -fomit-frame-pointer -Wall -I. -Iinclude -Itop/aprcl -Itop/cmdParser -Itop/ -Ims_include/ -Ifactor/gmp-ecm -I../ysieve -I../ytools -I../msieve/zlib -Wno-error=implicit-function-declaration -Wno-error=incompatible-pointer-types -Wno-error=return-mismatch -DVBITS=64 -Iaprcl -Ignfs/poly/stage1 -Ignfs/poly"
+}
+
+check() {
+ cd ${srcdir}/yafu
+ ./yafu 140870298550359924914704160737419905257747544866892632000062896476968602578482966342704
+ ./yafu -threads $(nproc) 2056802480868100646375721251575555494408897387375737955882170045672576386016591560879707933101909539325829251496440620798637813
}
package() {