summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32024-05-03 13:12:19 +0200
committergilcu32024-05-03 13:12:19 +0200
commita9dd96d953af9a73c341e2685196996033cd4ced (patch)
treea80e91fdf67922228b8c86ec8685ce859e9dac8f
parent395d59d32deabb33ad031604ed483a3a6d8996a5 (diff)
downloadaur-a9dd96d953af9a73c341e2685196996033cd4ced.tar.gz
upgpkg: yafu-git r611.53d86bb-1
fix compile
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--avx_ecm_main.patch20
3 files changed, 31 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a80fc9c06628..fcf23e449ca3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yafu-git
pkgdesc = Automated integer factorization.
- pkgver = r468.ca48c65
+ pkgver = r611.53d86bb
pkgrel = 1
url = https://github.com/bbuhrow/yafu
arch = x86_64
@@ -17,9 +17,11 @@ pkgbase = yafu-git
source = git+https://github.com/bbuhrow/ytools.git
source = git+https://github.com/bbuhrow/ysieve.git
source = msieve::svn+svn://svn.code.sf.net/p/msieve/code/trunk
+ source = avx_ecm_main.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 2fa4529955996166f4d258e2cb1a93685a4a8485129314d44fa3e140ae97e595
pkgname = yafu-git
diff --git a/PKGBUILD b/PKGBUILD
index b304b880ac31..7376cd2f3f45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=yafu
pkgname=yafu-git
pkgrel=1
-pkgver=r468.ca48c65
+pkgver=r611.53d86bb
pkgdesc="Automated integer factorization."
url=https://github.com/bbuhrow/yafu
license=("MIT")
@@ -19,13 +19,19 @@ source=(
"git+https://github.com/bbuhrow/ytools.git"
"git+https://github.com/bbuhrow/ysieve.git"
msieve::"svn+svn://svn.code.sf.net/p/msieve/code/trunk"
+ "avx_ecm_main.patch"
)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '2fa4529955996166f4d258e2cb1a93685a4a8485129314d44fa3e140ae97e595')
prepare() {
cd ${srcdir}/yafu
sed -i "s%^LIBS += -lecm /users/buhrow/src%#LIBS += -lecm /users/buhrow/src%" Makefile
sed -i "s/^\#LIBS += -lecm -lgmp -lytools -lysieve/LIBS += -lecm -lgmp -lytools -lysieve/" Makefile
+ patch --forward --strip=1 --input=../avx_ecm_main.patch
}
pkgver() {
diff --git a/avx_ecm_main.patch b/avx_ecm_main.patch
new file mode 100644
index 000000000000..418f281b4c72
--- /dev/null
+++ b/avx_ecm_main.patch
@@ -0,0 +1,20 @@
+diff --git a/factor/avx-ecm/avx_ecm_main.c b/factor/avx-ecm/avx_ecm_main.c
+index 660da8a..a7bcc6f 100644
+--- a/factor/avx-ecm/avx_ecm_main.c
++++ b/factor/avx-ecm/avx_ecm_main.c
+@@ -643,6 +643,7 @@ void vec_ecm_main(fact_obj_t* fobj, uint32_t numcurves, uint64_t B1,
+ printf("Using 1040-bit mul/sqr core\n");
+ }
+ }
++#ifdef USE_AVX512F
+ else if (tdata[0].MAXBITS > 16400)
+ {
+ // faster starting around 16000 bits on Xeon 6254
+@@ -654,6 +655,7 @@ void vec_ecm_main(fact_obj_t* fobj, uint32_t numcurves, uint64_t B1,
+ printf("Using karatsuba mul/sqr core\n");
+ }
+ }
++#endif
+ else
+ {
+ vecmulmod_ptr = &vecmulmod52;