summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkumax2022-07-23 22:03:01 +0800
committerkumax2022-07-23 22:03:01 +0800
commitee02fcda534ab909ced49bc29b2afa11c1bc8d30 (patch)
tree415b97c48a2cb8b7a97d737062971dc9f50a7f78
parent2af8988d76c98011e9015e5b52ee5b40dbb881b7 (diff)
downloadaur-ee02fcda534ab909ced49bc29b2afa11c1bc8d30.tar.gz
Fix the permissions of the executable files.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5575af329f2..67b39f53a4ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = yafu-git
license = MIT
depends = gmp
depends = gmp-ecm
+ optdepends = ggnfs
provides = yafu
provides = ysieve
conflicts = yafu
diff --git a/PKGBUILD b/PKGBUILD
index a1723c59f1b5..51859fbdfaea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ arch=('x86_64')
conflicts=(${_pkgbase})
provides=('yafu' 'ysieve')
depends=('gmp' 'gmp-ecm')
+optdepends=('ggnfs')
source=(
"git+https://github.com/bbuhrow/yafu.git"
"git+https://github.com/bbuhrow/ytools.git"
@@ -39,7 +40,7 @@ build() {
cp libytools.a ${srcdir}/ysieve/
cd ${srcdir}/ysieve
- make
+ make CC=gcc
cp libytools.a ${srcdir}/yafu/
cp libysieve.a ${srcdir}/yafu/
@@ -52,8 +53,8 @@ build() {
package() {
cd ${srcdir}/ysieve
- install -Dm644 ysieve ${pkgdir}/usr/bin/ysieve
+ install -Dm755 ysieve ${pkgdir}/usr/bin/ysieve
cd ${srcdir}/yafu
- install -Dm644 yafu ${pkgdir}/usr/bin/yafu
+ install -Dm755 yafu ${pkgdir}/usr/bin/yafu
}